aspose file tools*
The moose likes JForum and the fly likes Caching issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Caching issue" Watch "Caching issue" New topic
Author

Caching issue

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I have integrated JForum into my portal and ave enabled single sign on, so that the user need not login again. The jForum is displayed in a pop up window, and can be closed once is finished.

When I login first time, the JForum displays everthing fine and shows the following information -

Our users have posted a total of 1 messages
We have 2 registered users
The newest registered user is Anonymous There are 1 online users: 1 registered, 0 guest(s) [ Administrator ] [ Moderator ]
Most users ever online was 2 on 13/11/2005 06:46:42
Connected users: <<user name>>

I close JForum window, logout out of the application and log back in as a different user. When I invoke JForum again, it shows me the information of the last login and not the current login.

I tried using the logout code of User Action to close the sessions etc in db, but no luck so far. Looks like the browser is caching the pages or there is some other issue.

I donot get this problem if I use a browser instance. Please let me know if there is any solution for this, or if I am doing anything wrong.

Env - App server - JBOSS 4.0, JDK 1.4, OS - Fedora Linux

Thanks



[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
This is probably a bug
http://www.jforum.net/jira/browse/JF-433
[originally posted on jforum.net by Anonymous]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Caching issue