aspose file tools*
The moose likes JForum and the fly likes IE vs Firefox session issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "IE vs Firefox session issues" Watch "IE vs Firefox session issues" New topic
Author

IE vs Firefox session issues

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I am seeing some issues using IE 6.0 vs Firefox 1.5. Firefox is my normal browser but some people using IE are reporting problems.

Issue #1
In my testing if I am logged in as a user in firefox and hit the refresh button I stay logged in. If I hit the refresh button in IE I am logged out with the only indication being that my user name is no longer visible at the login/logout link at the top. I tested this on the jforum.net forum and I do not see the same problem (refresh works with both browsers) so I'm not sure what is going on with my site. One difference is that I have some forums hidden if you are not logged in. I don't know if this causes a difference. If I hit refresh with firefox I am not logged out.

Issue #2
When I am logged in as admin with IE and click the open moderation options link I get booted out with a message saying I don't have permission. This only happens on the forums that are hidden from users who are not logged in. For forums that are open to everyone I can open the moderation options in IE without problem. With firefox I can open the moderation options when logged in as admin for any forum and delete or move messages without problem.

Any ideas what may be going on?

[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
This was my original post. I thought I was logged in but some how I was not.
[originally posted on jforum.net by parisila]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Which JForum version? also, which application server are you using?

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I am running JForum 2.1.5 on tomcat 5.5.15 on Linux CentOS 4.

Also, I tested today at work and on my work computer refreshing with IE does not log me out like it does from my home pc.
[originally posted on jforum.net by parisila]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: IE vs Firefox session issues
 
Similar Threads
JSF navigation/back button problem
Are the Browser Wars back ?
Moderating forums
Forum <br /> issue after upgrade
Online Users Cache Not Refreshing Correctly