Two Laptop Bag*
The moose likes JForum and the fly likes JForum 2.1.6, Tomcat 5.5.4, JDK 1.5.0_04 installation fails!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "JForum 2.1.6, Tomcat 5.5.4, JDK 1.5.0_04 installation fails!!" Watch "JForum 2.1.6, Tomcat 5.5.4, JDK 1.5.0_04 installation fails!!" New topic
Author

JForum 2.1.6, Tomcat 5.5.4, JDK 1.5.0_04 installation fails!!

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
The installation of the current JForum fails on Tomcat 5.5.4 and JDK 1.5.0_04 while it completes without errors on the same machine using JDK 1.4.2_06 and Tomcat 4.1.6.

The database used is MySQL 4.1.5

As the installer fails with an exception in the Freemaker code, I expect the problem is related to the JDK.

Any clues?
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
What error are you getting? I would guess that since you're trying this under both 1.4 and 1.5 you've got the Tomcat compatibility libraries installed. Try a fresh install of Tomcat without the compatibility libraries. Also, Tomcat 5.5 is on 5.5.15 - you've got a very old Tomcat.
[originally posted on jforum.net by stdunbar]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi Rafael,

not quite. I will try to clarify things:

1. All tests were made on the same system with the same MySQL.
2. A test with Tomcat 4, JDK 1.4.2_06 and MySQL 4.1 worked fine.
3. All tests with Tomcat 5.5.x and JDK 1.5.0_04 failed with the above error message.
4. I have not been able to test against Tomcat 5 and JDK 1.4.2_06, because I do not have the compatibility libraries installed. These are required to use Tomcat 5+ with a 1.4 JDK.

I will try to set up a test case for JForum 2.1.6, Tomcat 5 with compat. libs and JDK 1.4 later today and keep all of you posted.

Cheers,
Tom
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Oh, I forgot to mention: The OS is Windows XP SP2, all updates installed. The production environment however is Debian Linux.

The installer fails with the same errors on both operating systems.

Tom
[originally posted on jforum.net by karazon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi stdunbar,

thanks for your answer.

I am using tomcat 5.5.4 without the compatibility libraries since it will only be started using a 1.5 JDK. And yes, I know the version is a little bit outdated. But for now I would really like to get this working, because upgrading the container on the production system might get me into other problems...

The error I get during the installation is:


I have tried the install on a freshly installed Tomcat 5.5.15 (current release) on the same system again using JDK 1.5.0_04 and it fails with the exact same error.

So I guess, it is really an issue with the JDK 1.5.0 update 4.

What do you think?

Cheers,
Tom
[originally posted on jforum.net by karazon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
So, are you saying that the same JForum-2.1.6.zip file works on a 1.4 vm, but not on a 1.5 vm, on the same SO, same database and same tomcat?

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello all,

I finally did the last pending test:

Tomcat 5.5.15 with compatibility libraries,
JDK 1.4.2_06,
MySQL 4.1,
and JForum 2.1.6.

The installation fails with the same error, already quoted above.

So the error is probably the result of an incompatibility with Tomcat 5.5. Please correct me, if I am wrong.

Summary:

JDK 1.4.2_06, Tomcat 4.1.6, MySQL 4.1 works.
JDK 1.4.2_06, Tomcat 5.5.15 (with compatibility libs), MySQL 4.1 fails.
JDK 1.5.0_04, Tomcat 5.5.15 (without compatibility libs), MySQL 4.1 fails.
JDK 1.5.0_04, Tomcat 5.5.4. (without compatibility libs), MySQL 4.1 fails.

All test were made on the same machine with Windows XP SP2 installed.

Cheers,
Tom

[originally posted on jforum.net by karazon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I'll try with Tomcat 5.5 here

If you could, please register this bug at http://www.jforum.net/jira, so I won't forget it!

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JForum 2.1.6, Tomcat 5.5.4, JDK 1.5.0_04 installation fails!!