This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

log4j:ERROR Could not open [null/WEB-INF/log4j.xml]

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm working on an installation of jforum on linux via pelsk. When I restarted Tomcat the forum stopped working and I see the following error on catalina.out.

log4j:ERROR Could not open [null/WEB-INF/log4j.xml].
java.io.FileNotFoundException: null/WEB-INF/log4j.xml (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java:583)
at org.apache.log4j.xml.DOMConfigurator.configure (DOMConfigurator.java:687)
at net.jforum.JForumCommonServlet.init(JForumCommonServlet.java:91)
at net.jforum.JForum.init(JForum.java:89)
at org.apache.catalina.core.StandardWrapper.loadServlet (Unknown Source)

Tomcat version is 4.1. Any help would be greatly appreciated.
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you run it outside plesk, it works?

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
ist there a solution tu run jforum on Plesk?
I have the same Problem "/etc/init.d/null/WEB-INF/log4j.xml" installing jforum via Plesk 8.1.0

help would be greatly appreciated

Cheers
Dieter
[originally posted on jforum.net by netdieter]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Don't know. It appears to be some problem related to war files.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tanx for your answer.
Well, you are right.
After deploying jforum as an exploded warfile, it worked.

Are there any plans to integrate a jarfileclassloader?

This would make it more easier for insatlation for exampel on plesk and others.

cheers
Dieter
[originally posted on jforum.net by netdieter]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please register this bug at http://www.jforum.net/jira

Thank you

Rafael
[originally posted on jforum.net by Rafael Steil]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic