aspose file tools*
The moose likes JForum and the fly likes Getting JForum to run with MS SQL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Getting JForum to run with MS SQL" Watch "Getting JForum to run with MS SQL" New topic
Author

Getting JForum to run with MS SQL

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi everyone,

First of all thanks to the JForum team for a great piece of software.

I need some help please...

From what I've read in previous posts it seems to be possible to get JForum to work with MS SQL.

And after some inital progress where it seemed I got JForum to install against MS SQL (I changed the install.htm file adding sqlserver as an option, manually changed the web-inf jforum config file and copied the CVS sqlserver directory to web-inf/config/database ) I am now kind of stuck.

Could someone advise me here please.

Thanks in advance.
Luth

P.S. I tried to get the guys to install MySQL but they won't budge.
[originally posted on jforum.net by luthrian]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
P.S.


sorry about the formatting....

[originally posted on jforum.net by luthrian]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Update:
- We got things running now :lol: but noticed that we need to rewrite some of the generic SQL queries - which we have started to do already ... successfully as it seems.

When we are finished we will be glad to contribute the SQL code to the JForum community.

Does anyone happen to know which sql statements need rewriting (especially of the 27 or so in the Forum Model).

We also would like to use the tests/core stuff from CVS for testing. Does it run out of the box?

Thanks,
Luth...
[originally posted on jforum.net by luthrian]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
There isn't any crude and direct way to do so

You will have to navigate through the system and check. Probably the pagination queries (*selectByLimit) should be worked on

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks Rafael,

I've attached the sqlserver file we are currently using. (I think we have covered the pagination issues but haven't tested it throughly)

Regards,
Luth


[originally posted on jforum.net by luthrian]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks, I'll add it to the cvs!

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

the following needs to be added to the sqlserver.sql file to get the Poll function to work.



regards,
luthrian
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Done, thanks.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi People,

I'm trying to deploy JForum with MSSQL.
I followed all steps wou mentioned but I have a specific doubt:

I want to use a DataSource and I just don't know where it must be located.

I got a "mssql-ds" not bound. (that's the name of mi DS). I put it in deploy folder of my JBoss server, and then I tried on other folders within JForum without success.

Please give a step by step guide to achieve it.

Thanks a lot in advanced.

Regards,

Martin.-
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
up
[originally posted on jforum.net by fieldz]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I wanted to get it running on SQL 2000 as well to try it out.
Any more detailed information on doing this yet?

Thanks
[originally posted on jforum.net by tmckinnon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I have the sqlserver dir from cvs but I don't see how to add it as an option on installation? Is there some other details on how to do this.

Thanks
[originally posted on jforum.net by tmckinnon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I edited the install.htm in the templates and added 'sqlserver'. This ran but the sql didn't work.

I manually executed the create script for the tables in enterprise manager and got an error on the following:



CREATE TABLE [jforum_vote_desc] (
[vote_id] [bigint] IDENTITY (1, 1) PRIMARY KEY CLUSTERED NOT NULL ,
[topic_id] [bigint] DEFAULT (0) NOT NULL ,
[vote_text] [varchar] (255) NOT NULL ,
[vote_start] [datetime] NOT NULL ,
[vote_length] [bigint] DEFAULT (0) NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]

because of the: TEXTIMAGE_ON [PRIMARY] - so I removed it.

Ran the install again and it appears to be working. Althought there is no default forums or postings so I will have to test.
[originally posted on jforum.net by tmckinnon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
well I got so far... now I have the DECLARE error I noticed in another post but no solution.

Trying to list users from the admin, forums etc all still break because of the Declare etc. I will switch to hsql for now.

at java.lang.Thread.run(Thread.java:534)
Caused by: java.sql.SQLException: Incorrect syntax near the keyword 'DECLARE'.
at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:365)
at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2781)
at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2224)
at net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:628)
at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQLQuery(JtdsStatement.java:418)
at net.sourceforge.jtds.jdbc.JtdsPreparedStatement.executeQuery(JtdsPreparedStatement.java:693)
at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeQuery(NewProxyPreparedStatement.java:76)
at net.jforum.dao.sqlserver.SqlServerUserDAO.selectAll(SqlServerUserDAO.java:78)
at net.jforum.view.admin.UserAction.list(UserAction.java:76)
... 35 more
[originally posted on jforum.net by tmckinnon]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
focus on

[originally posted on jforum.net by interpb]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Yeahh.. . while nobody else fix the sql server scripts, we will not add it to the installer.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi together

I have a project and the database (which is given) is a MSSQL.

So I tried to run JForum with the SQL-Server and here are the files to run JForum with MSSQL

One thing is open:
The file upload doesn't work yet.

As soon as I will have fixed it I will post the changes

Kind regards

PS: If there are still errors can u inform me, please?
[originally posted on jforum.net by stejan]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thank you, the file are in the cvs now.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks for the solutions provided in this thread. Worked fine for me right away!
Is there a way to make the file upload work?
[originally posted on jforum.net by aresolution]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Sorry ress the topic, but:

Some news for the file upload question?
[originally posted on jforum.net by Vitor Braga]
 
jQuery in Action, 2nd edition
 
subject: Getting JForum to run with MS SQL