aspose file tools*
The moose likes JForum and the fly likes java.lang.reflect.InvocationTargetException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "java.lang.reflect.InvocationTargetException" Watch "java.lang.reflect.InvocationTargetException" New topic
Author

java.lang.reflect.InvocationTargetException

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I get the error when deploy new topic, below is the exception window:
"An error has ocurred. For detailed stack trace, please see the page's source code.
java.lang.reflect.InvocationTargetException"

I don't know what wrong, any idea? thanks.
[originally posted on jforum.net by Nicklaus]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
When you get this error, please open the page's source code, grab the error message there, and paste there.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm also getting this error, but im my case the error occurs in the List page of forums. In the first page.

If I restart Tomcat the error doesn't occurs, but after some time it appear again.

the stack trace:


Any ideas ??

I'm running JForum in Tomcat 5.5.9, JRE 1.5, SO Centos 3.5

Thanks !!

[originally posted on jforum.net by jc_oz]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
<!-- BEGIN ERROR STACK TRACE <br /> java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:324) <br /> at net.jforum.Command.process(Command.java:116) <br /> at net.jforum.JForum.service(JForum.java:182) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:810) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157) <br /> at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157) <br /> at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214) <br /> at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) <br /> at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) <br /> at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198) <br /> at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152) <br /> at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) <br /> at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) <br /> at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137) <br /> at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) <br /> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) <br /> at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102) <br /> at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) <br /> at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) <br /> at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) <br /> at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) <br /> at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929) <br /> at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160) <br /> at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:793) <br /> at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:702) <br /> at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:571) <br /> at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:644) <br /> at java.lang.Thread.run(Thread.java:536) <br /> Caused by: com.octo.captcha.CaptchaException <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:547) <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:515) <br /> at com.octo.captcha.engine.image.ListImageCaptchaEngine.getNextImageCaptcha(ListImageCaptchaEngine.java:559) <br /> at net.jforum.entities.UserSession.createNewCaptcha(UserSession.java:402) <br /> at net.jforum.view.forum.UserAction.insert(UserAction.java:164) <br /> ... 34 more <br /> Caused by: java.lang.NoClassDefFoundError <br /> at java.lang.Class.forName0(Native Method) <br /> at java.lang.Class.forName(Class.java:140) <br /> at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:62) <br /> at com.octo.captcha.component.image.fontgenerator.RandomFontGenerator.getFont(RandomFontGenerator.java:495) <br /> at com.octo.captcha.component.image.fontgenerator.TwistedRandomFontGenerator.getFont(TwistedRandomFontGenerator.java:495) <br /> at com.octo.captcha.component.image.fontgenerator.TwistedAndShearedRandomFontGenerator.getFont(TwistedAndShearedRandomFontGenerator.java:494) <br /> at com.octo.captcha.component.image.wordtoimage.ComposedWordToImage.getFont(ComposedWordToImage.java:559) <br /> at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getAttributedString(AbstractWordToImage.java:528) <br /> at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getImage(AbstractWordToImage.java:512) <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:544) <br /> ... 38 more <br /> <br /> END ERROR STACK TRACE-->

I'm also getting this error, but im my case the error occurs when i try to add a new user
[originally posted on jforum.net by Anonymous]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Disable captcha for now. Open SystemGlobals.properties / jforum-custom.conf and set all keys starting with "captcha" to "false"

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I have the same problem in JForum-2.1.6 and Tomcat 4.1.31.

Setting all "captcha" to "false" in SystemGlobals.properties DOESN'T HELP!!! :twisted:

The error occurs each time when someone clicks the "Register" url.
The exception is as posted above with these lines in the bottom

Caused by: java.lang.NullPointerException
at net.jforum.repository.ForumRepository.getTotalMessages(ForumRepository.java:699)
at net.jforum.repository.ForumRepository.getTotalMessages(ForumRepository.java:684)
at net.jforum.view.forum.ForumAction.list(ForumAction.java:93)

My forums are not useable anymore
HELP :!::!::!:
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
We fixed this bug some days ago. Was a bizarre combination of factors. Most of the time, it should work if you refresh the page.

Anyway, the cvs version has this fixed.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael, I reinstalled 2.1.6 from CVS, but the problem persists (note different line numbers in the exception's stack trace below)

www.selldesk.com

Caused by: java.lang.NullPointerException
at net.jforum.repository.ForumRepository.getTotalMessages(ForumRepository.java:663)
at net.jforum.repository.ForumRepository.getTotalMessages(ForumRepository.java:648 )
at net.jforum.view.forum.ForumAction.list(ForumAction.java:92)
... 43 more

HELP :!: :!: :!:
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I got it too, on CVS I checked out on may 3. But a tomcat and postgres restart made it go away for now.

The forum had been working for another user just minutes prior, but when I logged in and replied to an older topic I got got java.util.Date error, then a java.lang.reflect.InvocationTargetException error (sorry I'll do that page source thing next time).

I received topic reply notification but the message had not posted. Posts to other topics weren't working either for me but I noticed somehow (don't remember) a post made it without updating the timestamp on the topic list. Maybe that was after the restart.

However, the timestamp eventually cleared up and things are working now.

HTH. -ken
[originally posted on jforum.net by ken0]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Yeah, I have seen this problem occur in version 2.1.6. It was a silly mistake on the cache management.

The CVS version should work fine

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
sorry! I posted to the wrong forum a bit ago: I am still having this date problem, but I captured some error messages this time:

I applied the CVS code from today and still get the same error when posting a reply (not new topic) this time:

<!-- BEGIN ERROR STACK TRACE <br /> java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:585) <br /> at net.jforum.Command.process(Command.java:116) <br /> at net.jforum.JForum.service(JForum.java:183) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:802) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) <br /> at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) <br /> at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213) <br /> at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:17 <br /> at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126) <br /> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105) <br /> at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107) <br /> at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:14 <br /> at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869) <br /> at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667) <br /> at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527) <br /> at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80) <br /> at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) <br /> at java.lang.Thread.run(Thread.java:595) <br /> Caused by: java.lang.ClassCastException: java.util.Date <br /> at java.sql.Timestamp.compareTo(Timestamp.java:474) <br /> at net.jforum.entities.TopicTypeComparator.compare(TopicTypeComparator.java:62) <br /> at java.util.Arrays.mergeSort(Arrays.java:1284) <br /> at java.util.Arrays.sort(Arrays.java:1223) <br /> at java.util.Collections.sort(Collections.java:159) <br /> at net.jforum.repository.TopicRepository.addTopic(TopicRepository.java:247) <br /> at net.jforum.view.forum.common.TopicsCommon.updateBoardStatus(TopicsCommon.java:275) <br /> at net.jforum.view.forum.PostAction.insertSave(PostAction.java:1127) <br /> ... 24 more <br /> <br /> END ERROR STACK TRACE-->

...tho it seems to be cut off.

And I was wondering if there were anything I could do in the meantime, maybe with the "Cached data" administration?

thanks for the support! -ken
[originally posted on jforum.net by ken0]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Not expecting an answer over the weekend, I just remembered maybe a significant clue, that this may be happening only when the preview button is used.

But I'll have to check later b/c it is the w/e you know
[originally posted on jforum.net by ken0]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ah, crapy Java date manipulation.

I'll fix it. Thanks for reporting.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, I did some fixed and sent to the cvs.

If you guys could check it, please report the results!

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
After install of today's CVS and startup, the mis-ordered (by date) posts re-ordered correctly. And some tests of replies and new topics with/out preview and with/out uploads seems okay so far.

It was intermittent before, but seems okay to me now.

Thanks again for the speedy turn around.
-ken
[originally posted on jforum.net by ken0]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I re-installed, too, and threads are still not ordered when a new message posted to an older topic. That topic stays down in the list, but last message displayed with correct current time. Newer topic but with older last messages stays in the top. This is not correct. Please fix.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Please fill an entry at Jira - http://www.jforum.net/jira

Thanks

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi Rafael,
I opened a new issue http://www.jforum.net/jira/browse/JF-517

I hope you can fix this.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I sure will.

Thanks for registering it.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: java.lang.reflect.InvocationTargetException
 
Similar Threads
InvocationTargetException java.lang.NoSuchMethodError
Axis2 with eclipse
java.lang.reflect.InvocationTargetException: ResultSet is cl
ResultSet is closed !
error for tomcat installation on xp