• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Register New User/Member

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I try to register a new user/member I get "An error has occurred.

Thnaks for the help in advance

Here is the dump

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at net.jforum.Command.process(Command.java:116)
at net.jforum.JForum.service(JForum.java:182)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
at com.caucho.server.http.FilterChainFilter.doFilter(FilterChainFilter.java:88)
at com.caucho.server.http.Invocation.service(Invocation.java:315)
at com.caucho.server.http.RunnerRequest.handleRequest(RunnerRequest.java:346)
at com.caucho.server.http.RunnerRequest.handleConnection(RunnerRequest.java:274)
at com.caucho.server.TcpConnection.run(TcpConnection.java:139)
at java.lang.Thread.run(Thread.java:534)
Caused by: com.octo.captcha.CaptchaException
at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:547)
at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:515)
at com.octo.captcha.engine.image.ListImageCaptchaEngine.getNextImageCaptcha(ListImageCaptchaEngine.java:559)
at net.jforum.entities.UserSession.createNewCaptcha(UserSession.java:402)
at net.jforum.view.forum.UserAction.insert(UserAction.java:164)
... 15 more
Caused by: java.lang.NoClassDefFoundError
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:141)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:62)
at com.octo.captcha.component.image.fontgenerator.RandomFontGenerator.getFont(RandomFontGenerator.java:495)
at com.octo.captcha.component.image.fontgenerator.TwistedRandomFontGenerator.getFont(TwistedRandomFontGenerator.java:495)
at com.octo.captcha.component.image.fontgenerator.TwistedAndShearedRandomFontGenerator.getFont(TwistedAndShearedRandomFontGenerator.java:494)
at com.octo.captcha.component.image.wordtoimage.ComposedWordToImage.getFont(ComposedWordToImage.java:559)
at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getAttributedString(AbstractWordToImage.java:528)
at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getImage(AbstractWordToImage.java:512)
at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:544)
... 19 more

END ERROR STACK TRACE-->
[originally posted on jforum.net by brian662]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using Apache/Debian/Resin/mySQL

Thanks again.

Brian
[originally posted on jforum.net by brian662]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I faced the same problem.
i resolved the problem by simply reinstall it.
[originally posted on jforum.net by manic]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You will have to disable Catpcha.

Open your SystemGlobals.properties / jforum-custom.conf and set to "false" the keys "captcha.posts" and "captcha.registration"

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i faced d same problem and it get solved by disabling captcha. But why i shud disable captcha ... it'll be insecure .. and forum may be attacked by some scripts ... plz suggest something ...
[originally posted on jforum.net by kulbirsaini]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Kulbir, so far it's not clear why those errors occur with the captcha library. It simply does not make any sense.

If someone has something that may help, please share with us!

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This happens because you don't have X available.
You need to run Xvfb, then the captcha will work. This is how I do it.

Cheers.

[originally posted on jforum.net by MarkSwanson]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic