This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

need to create this activation key based approach for user registration

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I needed to create this activation key based approach for user registration, that a user gets registered only when he:
1. fills the user creation form in application.
2. gets an email with an activation link
3. goes to the link to activate account

I noticed an entry in user POJO called activationKey. There's also a a method activateAccount in UserAction.

Any relations between the two? Any suggestions on how can i implement the new functionality resuing some stuff in here
[originally posted on jforum.net by vikram.arora.in]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is already implemented. Just enable it at Admin Panel -> Configurations -> Mail -> Requires user to authenticate email

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks Rafael !! u r the best!
[originally posted on jforum.net by vikram.arora.in]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have Requires user to authenticate email enabled.
But the user can befor he activate his acount post.
I use the version 2.1.6

can sombody help me
[originally posted on jforum.net by JK]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the post being done as the Anonymous user or the unactivated user? E.g., what id shows up on the posting.

If it's anonymous, you need to remove the anonymous user from the General group and add it to a (probably new) group that can't post.

If the un-authenticated user is showing up, then it may be a configuration issue or bug. And more details will be needed.
[originally posted on jforum.net by monroe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The un-authenticated user is showing up.
But I have create the user for testing the email authentication and so the user has the same ip as an authenticated user.
Is that a problem?
[originally posted on jforum.net by JK]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
is anything wrong in this settings for the user authentication?


[originally posted on jforum.net by JK]
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic