This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JForum and the fly likes SSO cookies not being read Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "SSO cookies not being read" Watch "SSO cookies not being read" New topic
Author

SSO cookies not being read

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Can you please help me with my error with implementing sso on version 2.1.6

I have set the SystemGlobal.properties

authentication.type = sso
sso.implementation = net.jforum.sso.MyUserSSO

In MyUserSSO authenticateUser method I want to read the cookie I set in my app, but my set cookie is never seen by Jforum.

I verify that the cookie is set in my App and then I click the link to Jforum and don�۪t see any cookies beside JSessionID

My cookie that I am checking for has a null path and domain value.


Please help.

[originally posted on jforum.net by skinsFan]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Is the cookie path correct? I mean, it is visible to where JForum is?

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
The cookie path is null. Do I need to set it for Jforum to read it?
[originally posted on jforum.net by skinsFan]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: SSO cookies not being read
 
Similar Threads
Webapp Integration -- SSO issues
Not able to retrieve cookie information
SSO with JForum
SSO with Cookies
SSO /redirect / anonymous users