Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

log in problem, all members can access control panel

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When new members register or even excisting members log in they can get access to the the admin area. I've checked all the settings and they are under general and permissions is set to the right settings.

What is causing this problem?

Thanks
[originally posted on jforum.net by sunnycool]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am running a number of JForums experiencing this problem, can someone please advise on how to fix it? Is a retrograde necessary?
[originally posted on jforum.net by Clock'd 0Ne]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That sounds very strange.

First of all, make sure all your users belong only to the "General" group.

If you dont' want to manually do this, go to your database administration console and fetch all records from jforum_groups, and then match the group ids to the records of jforum_user_groups.

I would recommend either set again the permissions for all groups, and restart Tomcat, just to make sure there is no cached data left.

Btw, which JForum version and database are you using?

Rafael
[originally posted on jforum.net by Rafael Steil]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic