File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JForum and the fly likes New Tomcat 5.5.17 ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "New Tomcat 5.5.17 ?" Watch "New Tomcat 5.5.17 ?" New topic
Author

New Tomcat 5.5.17 ?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I run JForum 2.1.7 under Tomcat 4.1.31.

I just upgraded to Tomcat 5.5.17 and shortly tested JForum. The forum seems to work properly and I currently don't found any problem. However my test is quick.

1. Can you confirm that JForum 2.1.7 can run under Tomcat 5.5.17 ?
2. Which newest release of MySQL database do you recommend for JForum 2.1.7 ?
3. Are there any limits for other newest software releases?
4. What is the current release of JForum to run in production server?

Thanks
Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny,

It should work fine under 5.5.17.

If you need cyrilic support (through unicode), I'd recommed using mysql 4.0.27, as the jdbc driver works well. I have serious problems starting from version 4.1 of mysql (including the 5.x series) with cyrillic data and Java.

Version 2.1.7, even the cvs one, should be the most stable version available, and have important improvements.

As you already know, when I say "next version is comming next week", you can add two months to the math .. That's not beacuse JForum is not working, that's only because I keep saying "tomorow I'll release it", but...

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael thanks!
Can you recommend an upgrade procedure from MySQL 3.23.58 to 4.0.27, both MySQL and JForum scripts/tables ?

Thanks
Evgeny
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
The database structure does not need to change, considering you're not changing JForum's version.

About configuration: in your mysql.properties, set the keys below to the values shown:



(mysql 323 config is "MySQL323DataAccessDriver")

Also, remove all values from "mysql.sql"

That's all!

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Rafael Steil wrote:If you need cyrilic support (through unicode), I'd recommed using mysql 4.0.27, as the jdbc driver works well. I have serious problems starting from version 4.1 of mysql (including the 5.x series) with cyrillic data and Java.

I use Tomact 5.5.17 + Mysql 5.0.22 UTF8 => no problems with cyrillic.
[originally posted on jforum.net by VVD]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
VVD, can you provide details how you enabled cyrillic in JForum with Mysql 5.0.22 ?
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Do u speak Russian? :-)
Set UTF8 in all configs. ;-)
[originally posted on jforum.net by VVD]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Yes, I do.

Can you list configuration files where the UTF-8 should be set? May be provide exactly code.
Is this differ from my current MySQL 3.23.58 settings ?

I heard that tables in MySQL 5.x should be created with UTF-8 argument, and then all Java driver configuration parameters should be ommited, as they are no longer in use. Is that true?
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
http://www.coderanch.com/t/576312
[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok thank you, I will try.

?� ???� ��a?� ?� ???� ?�o??�??� ?�o��?�??�� �� AnotherGuest �ۄĄ?�??�a�? ?�o?�?��o???�a ???� ��a?�o��a?�a ??a ?�?�??��?��??�.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:Ok thank you, I will try.

?� ???� ��a?� ?� ???� ?�o??�??� ?�o��?�??�� �� AnotherGuest �ۄĄ?�??�a�? ?�o?�?��o???�a ???� ��a?�o��a?�a ??a ?�?�??��?��??�.


hz
[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Serge Maslyukov wrote:
Evgeny wrote:Ok thank you, I will try.

?� ???� ��a?� ?� ???� ?�o??�??� ?�o��?�??�� �� AnotherGuest �ۄĄ?�??�a�? ?�o?�?��o???�a ???� ��a?�o��a?�a ??a ?�?�??��?��??�.


hz


What is "hz"?
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:
Serge Maslyukov wrote:
Evgeny wrote:Ok thank you, I will try.

?� ???� ��a?� ?� ???� ?�o??�??� ?�o��?�??�� �� AnotherGuest �ۄĄ?�??�a�? ?�o?�?��o???�a ???� ��a?�o��a?�a ??a ?�?�??��?��??�.


hz


What is "hz"?


?�?� �?��?? ?�?���?�???�?���Ą�?� ?�??�Ą� �ۄĄ?�??�?�� �??�???, ???�???�???���?��?��?�� - �? ???� ?�???��?
[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
LOL
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
?� �???��ۄ? ��Ą� ?� ?�?�?� ???�??�? ??�?�� ??��???���?�?�?�. :-)
?�?���?�?�??��?�?�???
[originally posted on jforum.net by VVD]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
?� ?���?� ???� ?���o?�o??a?�.

?�?�??�? ?�o?Ȅ΄�?� ??�??�??o ?�?��??�o?�o?�� ?�a?� ?�?���?�???��?��?� ��a?�?�?�� ?�?� MySQL 3.23.58 ?? 5.x ? ??a?�?�?� ?���?� ?���o?�?�?�??��, o�??�?�???o �? ��a?�?�?�a???�, ??o??�Ą� ?�o�???��΄?�? ?���?� ?�?���?���o?�?� ??a 5.x. ?�o?�?��� ?? ?�??��?���???���?� ?��?��� �ۄ�?�o??o?��?��??o ?�a?� ?�?���?���o?�?��� �? 3.23.58 ?? 5.x ?
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:
Serge Maslyukov wrote:
Evgeny wrote:Ok thank you, I will try.

?� ???� ��a?� ?� ???� ?�o??�??� ?�o��?�??�� �� AnotherGuest �ۄĄ?�??�a�? ?�o?�?��o???�a ???� ��a?�o��a?�a ??a ?�?�??��?��??�.


hz


What is "hz"?


???��??�???Ȅ�?�?? �? ?�???��? ?�?� - �?��?? "��*�� ?�???�?���" ?�?�?� "��*?? ?�???�?���"
???��??��?� ???�?�???�?��?�?� ?�???�?�


[originally posted on jforum.net by AnotherGuest]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:?� ?���?� ???� ?���o?�o??a?�.

?�?�??�? ?�o?Ȅ΄�?� ??�??�??o ?�?��??�o?�o?�� ?�a?� ?�?���?�???��?��?� ��a?�?�?�� ?�?� MySQL 3.23.58 ?? 5.x ? ??a?�?�?� ?���?� ?���o?�?�?�??��, o�??�?�???o �? ��a?�?�?�a???�, ??o??�Ą� ?�o�???��΄?�? ?���?� ?�?���?���o?�?� ??a 5.x. ?�o?�?��� ?? ?�??��?���???���?� ?��?��� �ۄ�?�o??o?��?��??o ?�a?� ?�?���?���o?�?��� �? 3.23.58 ?? 5.x ?


Backup ?�?�?�� ?� restore.

?� ��?�?� ???���?� MyISAM ?�?�?�� ?���??�?��?? �??�???�?��???�?� (��?�???Ȅ� ?�?�?��), ?� ?�??��??? ?�?�?�?��Ą? ��?�?�?�?�� �ۄ�?�?�???� �??�?�?�?�?� InnoDB (?�?�?�??? ?�� �� ???�??�? ???� ??? ?���?�??).
[originally posted on jforum.net by VVD]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I upgraded to MySQL 5.0.

The mysql.properties has this line
dao.driver=net.jforum.dao.mysql.MysqlDataAccessDriver
and all lines in mysql.sql are commented with the "#" mark.

Now I see gibberish after JForum startup.


dbencoding=UTF-8
dbunicode=true
database.connection.string=jdbc:mysql://${database.connection.host}:${database.connection.port}/${database.connection.dbname}?user=${database.connection.username}&password=${database.connection.password}&autoReconnect=true&useUnicode=${dbunicode}&characterEncoding=${dbencoding}&useNewIO=false&zeroDateTimeBehavior=convertToNull&useServerPrepStmts=false


Please advice.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:I upgraded to MySQL 5.0.

The mysql.properties has this line
dao.driver=net.jforum.dao.mysql.MysqlDataAccessDriver
and all lines in mysql.sql are commented with the "#" mark.

Now I see gibberish after JForum startup.


dbencoding=UTF-8
dbunicode=true
database.connection.string=jdbc:mysql://${database.connection.host}:${database.connection.port}/${database.connection.dbname}?user=${database.connection.username}&password=${database.connection.password}&autoReconnect=true&useUnicode=${dbunicode}&characterEncoding=${dbencoding}&useNewIO=false&zeroDateTimeBehavior=convertToNull&useServerPrepStmts=false


Please advice.


http://www.coderanch.com/t/576312
[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Can you shortly tell me what to do?
I see Russian in the database console, but gibberish in JSP after data read via ConnectorJ.
It worked fine in MySQL 3.23.58

SHOULD I do
create database jj charset=utf8;
instead of
create database jj
?
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:Can you shortly tell me what to do?
I see Russian in the database console, but gibberish in JSP after data read via ConnectorJ.
It worked fine in MySQL 3.23.58

SHOULD I do
create database jj charset=utf8;
instead of
create database jj
?


Short answer - yes

and check status of your mysql db installation
[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm just curious is there any way to handle UTF-8 via driver parameters and not via
"create database foo charset=utf8;" ?

After "create database foo charset=utf8" the "status" command prints the following:
...
Server version: 5.0.22-log
Protocol version: 10
Connection: Localhost via UNIX socket
Server characterset: latin1
Db characterset: utf8
Client characterset: latin1
Conn. characterset: latin1


Gibberish remains in web browser.
[originally posted on jforum.net by Evgeny]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Evgeny wrote:I'm just curious is there any way to handle UTF-8 via driver parameters and not via
"create database foo charset=utf8;" ?

After "create database foo charset=utf8" the "status" command prints the following:
...
Server version: 5.0.22-log
Protocol version: 10
Connection: Localhost via UNIX socket
Server characterset: latin1
Db characterset: utf8
Client characterset: latin1
Conn. characterset: latin1


Gibberish remains in web browser.


true connect string for jdbc driver 5.x is:

jdbc:mysql://localhost/test?useUnicode=true&characterEncoding=utf8&zeroDateTimeBehavior=convertToNull

[originally posted on jforum.net by Serge Maslyukov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Unfortunately this URL doesn't help.
[originally posted on jforum.net by Evgeny]
 
Consider Paul's rocket mass heater.
 
subject: New Tomcat 5.5.17 ?