aspose file tools*
The moose likes JForum and the fly likes Error JForum 2.1.6: LastPostInfo Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Error JForum 2.1.6: LastPostInfo" Watch "Error JForum 2.1.6: LastPostInfo" New topic
Author

Error JForum 2.1.6: LastPostInfo

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

I will get following error, if I open my jforum:

Method public static net.jforum.entities.LastPostInfo net.jforum.repository.ForumRepository.getLastPostInfo(int) throws java.lang.Exception threw an exception The problematic instruction: ---------- ==> assignment: lpi=fir.getLastPostInfo(forum.id) [on line 41, column 41 in default/forum_list.htm] ---------- Java backtrace for programmers: ---------- freemarker.template.TemplateModelException: Method public static net.jforum.entities.LastPostInfo net.jforum.repository.ForumRepository.getLastPostInfo(int) throws java.lang.Exception threw an exception at freemarker.ext.beans.OverloadedMethodModel.exec(OverloadedMethodModel.java:129) at freemarker.core.MethodCall._getAsTemplateModel(MethodCall.java:93) at freemarker.core.Expression.getAsTemplateModel(Expression.java:89) at freemarker.core.Assignment.accept(Assignment.java:90) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.MixedContent.accept(MixedContent.java:92) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.IteratorBlock$Context.runLoop(IteratorBlock.java:160) at freemarker.core.Environment.visit(Environment.java:351) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:95) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.MixedContent.accept(MixedContent.java:92) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.IteratorBlock$Context.runLoop(IteratorBlock.java:160) at freemarker.core.Environment.visit(Environment.java:351) at freemarker.core.IteratorBlock.accept(IteratorBlock.java:95) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.MixedContent.accept(MixedContent.java:92) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.Environment.process(Environment.java:176) at freemarker.template.Template.process(Template.java:231) at net.jforum.JForum.service(JForum.java:198) at javax.servlet.http.HttpServlet.service(HttpServlet.java:802) at sun.reflect.GeneratedMethodAccessor170.invoke(Unknown Source) at


After login and logut from the forum, the error wasn't shown and the forum works.

Has someone an idea?

kind regards,

F.O.
[originally posted on jforum.net by F.O.]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I have met this issue too when i deployed it in jboss and used Datasource. Anyone has resolved it?
[originally posted on jforum.net by foolfish]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I haven't seen it for a while. Should be ok

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error JForum 2.1.6: LastPostInfo