This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes JForum and the fly likes JForum is not working with the IP address Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "JForum is not working with the IP address" Watch "JForum is not working with the IP address" New topic
Author

JForum is not working with the IP address

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
koolnsmart wrote:Hi, I am using apache-tomcat-5.5.20 as a web server and mysql-5.0.18-2.1 as the backend for jforum in Fedora Core 5. When I use http://localhost:8080/jforum in firefox it is woking fine. I placed the complete directory of jforum from apache-tomcat-5.5.20/webapps to /var/www/html and I replaced all "localhost" entries with my IP address in jforum-custom.conf, located in /var/www/html/jforum/WEB-INF/config. But I cannot access this from using my IP address. Firefox is giving the error....

Not Found

The requested URL /jforum/forums/list.page was not found on this server.

I am new to web servers. Can any one advice me how to fix this?

This has nothing to do with using an IP ... but how you are trying to integrate the Java app in Apache! You can't just copy the java app files into the Apache html directory and have Apache serve the java app pages.

Do a search for jk_worker or Tomcat/Apache integration and set up the jk_worker file so that Apache knows to send the java app pages to the Tomcat app server. (after moving the JForum files back to where they were originally installed)
[originally posted on jforum.net by GatorBait3]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi, I am using apache-tomcat-5.5.20 as a web server and mysql-5.0.18-2.1 as the backend for jforum in Fedora Core 5. When I use http://localhost:8080/jforum in firefox it is woking fine. I placed the complete directory of jforum from apache-tomcat-5.5.20/webapps to /var/www/html and I replaced all "localhost" entries with my IP address in jforum-custom.conf, located in /var/www/html/jforum/WEB-INF/config. But I cannot access this from using my IP address. Firefox is giving the error....

Not Found

The requested URL /jforum/forums/list.page was not found on this server.



I am new to web servers. Can any one advice me how to fix this?
[originally posted on jforum.net by koolnsmart]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JForum is not working with the IP address