Bookmark Topic Watch Topic
  • New Topic

can't upload avatar in 2.1.6

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
Have you tried to add -Djava.awt.headless=true as startup-parameter to you appserver?
[originally posted on jforum.net by lazee]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
I have a strange problem with 2.1.6 after upgraded from 2.0.2. I can't upload avatar. Although the dimension and size of the picture is safely under the limit. I got an error like,




or,


[originally posted on jforum.net by dostoevsky]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
lazee wrote:Have you tried to add -Djava.awt.headless=true as startup-parameter to you appserver?


I tried this trick, but the error is still there when I try to upload my avatar.



The error info in the html source is,



[originally posted on jforum.net by dostoevsky]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
Have you also created a 'tmp' directory inside your webapp? (Think someone else pointed out this trick. But I'm not sure if this was related)
[originally posted on jforum.net by lazee]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
I already created a tmp directory in application directory, to solve thre problem that can't attach large file in post. This seems has nothing to with this problem.
[originally posted on jforum.net by dostoevsky]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
Maybe you can find something usefull in this discussion:

http://forum.java.sun.com/thread.jspa?threadID=205428&messageID=1377726
[originally posted on jforum.net by lazee]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
lazee wrote:Maybe you can find something usefull in this discussion:

http://forum.java.sun.com/thread.jspa?threadID=205428&messageID=1377726


Thanks a lot for your patience, Lazee! I guess I didn't add the headless parameter right. This time, I added the following line in catalina.sh,

It's working now!

[originally posted on jforum.net by dostoevsky]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Report post to moderator
Great
[originally posted on jforum.net by lazee]
 
    Bookmark Topic Watch Topic
  • New Topic