Meaningless Drivel is fun!*
The moose likes JForum and the fly likes Jira is back in business. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Jira is back in business." Watch "Jira is back in business." New topic
Author

Jira is back in business.

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Please tell me if something is still wrong.
[originally posted on jforum.net by lazee]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Not a Jira problem but maybe a jForum bug? In the forum list, subject says:

Jira is down today

but the posts says:

Jira is back in business

I assume that the post was edited after the problem fixed but there's a bug (feature?) in that the topic title stays the same?
[originally posted on jforum.net by monroe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
monroe wrote:Not a Jira problem but maybe a jForum bug? In the forum list, subject says:

Jira is down today

but the posts says:

Jira is back in business

I assume that the post was edited after the problem fixed but there's a bug (feature?) in that the topic title stays the same?


This is a bug indeed. I will fix.
[originally posted on jforum.net by lazee]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
lazee wrote:
monroe wrote:Not a Jira problem but maybe a jForum bug? In the forum list, subject says:

Jira is down today

but the posts says:

Jira is back in business

I assume that the post was edited after the problem fixed but there's a bug (feature?) in that the topic title stays the same?


This is a bug indeed. I will fix.


Turns out that I'm not able to recreate this
[originally posted on jforum.net by lazee]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
error when attach file
[originally posted on jforum.net by diana]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
diana wrote:error when attach file


Fixed! Thank you for reporting this
[originally posted on jforum.net by lazee]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi there,

I'm trying to access The JIRA instance for JForum but I'm getting a 503 error when trying to access: http://jira.jforum.net/

Is it down at the moment?
[originally posted on jforum.net by rowdyrabbit]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm trying to access The JIRA instance for JForum but I'm getting a 503 error when trying to access.


This is happening to me too, so I'll post the bug here:

JForum 2.1.8
Fedora 10
MySQl

After setting some rankings users with 0 posts have the top ranking name (in my case the one that is reserved for 1000 posts) and not the lowestone ^^
[originally posted on jforum.net by alos]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
We have dropped Jira because it cost too much server resources (aka, $$$) to maitain it. I'm configuring Redmine at support.jforum.net, but it is not 100% yet.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi to Jfourm Team,
I had found a bugin the existing jforum which is in live (i.e) from where i had posted the reply.The issue is wild card search when trying to search the wild card it throws an exception ,i think this is serious one so if it is fixed it will be very useful.(u can also try by searching * or ? .......)

Thanks
Rajesh

[originally posted on jforum.net by rb68626]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
#
[originally posted on jforum.net by liswot]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
,,,,,,,,,,,,,,,,,,,
[originally posted on jforum.net by Mr.vmt]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
lazee wrote:Please tell me if something is still wrong.

[originally posted on jforum.net by wolfcame]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Test :?: :idea:
[originally posted on jforum.net by mozalex5]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello Everyone,

Could anyone plz tell me how to configure Jforum with the Apache Tomcat 6?

I have installed the apache tomcat and then unzip the Jforum file and copied it to the directory named "C:\Apache\webapps" (If I am not mistaken this is what was suppose to be done) and then I startup the Apache Tomcat server and wrote "http://localhost:8080/Jforum" in the web browser but it didn't work. I get the following page on my browser, please help me to correct this or give me step by step instructions to register the JForum application within Tomcat:

-----------------------------------------------------
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet.init() for servlet jforum threw exception
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

net.jforum.exceptions.DatabaseException: Error while trying to start the database: net.jforum.exceptions.DatabaseException: java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:46
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:7
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

net.jforum.exceptions.DatabaseException: java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:46
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:7
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:46
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:7
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

com.mchange.v2.resourcepool.TimeoutException: The pool timed out while waiting to acquire a resource -- timeout at awaitAvailable()
com.mchange.v2.resourcepool.BasicResourcePool.awaitAvailable(BasicResourcePool.java:1157)
com.mchange.v2.resourcepool.BasicResourcePool.prelimCheckoutResource(BasicResourcePool.java:405)
com.mchange.v2.resourcepool.BasicResourcePool.checkoutResource(BasicResourcePool.java:351)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:466)
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:7
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


note The full stack trace of the root cause is available in the Apache Tomcat/6.0.20 logs.


------------------------------------
[originally posted on jforum.net by deepakarora01]
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Jira is back in business.