aspose file tools*
The moose likes JForum and the fly likes Can't create new topics in JForum 2.1.7 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Can Watch "Can New topic
Author

Can't create new topics in JForum 2.1.7

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Have just installed JForum 2.1.7 with Oracle 10g. Unfortunately I'm not able to create new topics in the forum. Getting this error:

ORA-01006: bind variable does not exist

Does this means that JForum are trying to issue a bind call for a variable that are not listed in the corresponding SQL statement?

The full stack trace:




[originally posted on jforum.net by Christer]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Strange I have installed JForum with Oracle. But in the log I get this information on startup:



So I thought, why are JForum loading MysqlDataAccessDriver?

Found the setting in jforum-custom.conf file. Changed it to

Now I get a different error when creating a new topic:



I'm confused here. Did the installer miss some other settings as well? How stable are JForum on Oracle anyway :?

[originally posted on jforum.net by Christer]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

looks like your Oracle JDBC Driver is not up to date.
Just download the latest version from oracle's website.
[originally posted on jforum.net by Five-O]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
looks like your Oracle JDBC Driver is not up to date.


I'm using the latest oracle Drivers - ojdbc14.jar. It's the same that comes with JForum.



[originally posted on jforum.net by Christer]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Five-O - you're right and I'm wrong ops:

I did use JForums Oracle drivers. But it turned out that JForum 2.1.7 comes with an old odjbc14.jar :?:

Switched to the latest drivers and now I can start play with my new forum


[originally posted on jforum.net by Christer]
 
jQuery in Action, 2nd edition
 
subject: Can't create new topics in JForum 2.1.7