jQuery in Action, 2nd edition*
The moose likes JForum and the fly likes Error while trying to configure the database Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Error while trying to configure the database" Watch "Error while trying to configure the database" New topic
Author

Error while trying to configure the database

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I've just installed Jforum 2.17b3 on a Windows XP SP2 machine, running a Resin app server (v2.1.9).

I kicked off the jforum installation wizard using the following options:
Database type: HSQLDB
Connection Type: JDBC
Data Source Name: blank
Database Server Hostname: blank
Database Port: blank
Database name: blank
Database Username: blank
Database Password: password
Database Encoding: Other
Use Connection Pool: No
Administrator password: password

When I click the "Begin Installation" button I get an error:

"Error while trying to configure the database. Please check if parameters like username, password and host are correct and try again.
org.hsqldb.jdbcDriver"

I'm a bit of a newbie, and not a Java developer, although I have a familiarity with some Java and app server concepts. Do I need to configure JDBC before attempting to install Jforum?
[originally posted on jforum.net by itm]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
You can't let parameter blank...

You must check Database Server Hostname, Database Port etc... Because naturally, jforum use database ;)
[originally posted on jforum.net by tinico]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm following right behind itm, running into the same problems, but in an OS X installation.

tinico wrote:You can't let parameter blank...

You must check Database Server Hostname, Database Port etc... Because naturally, jforum use database ;)


So the install instructions are also incorrect ? Do you know which ones ?

Do you know who edits the web pages and if there is a way of helping correct some of the mistakes ?

Thanks,


-Sven
[originally posted on jforum.net by Sven_G]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error while trying to configure the database
 
Similar Threads
JForum with SQL Server
Connecting to MSSQL2000
Connection Refused Error running in WAS 4.0 AEs
Cannot open connection issue
Invalid user error message