aspose file tools*
The moose likes JForum and the fly likes error while inserting new message and new user Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "error while inserting new message and new user" Watch "error while inserting new message and new user" New topic
Author

error while inserting new message and new user

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I have 2.1.7 jforum
Mysql version : 5.0.18
Tomcat :5.5.23

When i try to insert new message or add a new user. I get error message:

Here are the details :

<!-- BEGIN ERROR STACK TRACE <br /> net.jforum.exceptions.ForumException: java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:585) <br /> at net.jforum.Command.process(Command.java:117) <br /> at net.jforum.JForum.processCommand(JForum.java:220) <br /> at net.jforum.JForum.service(JForum.java:203) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:803) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188) <br /> at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59) <br /> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215) <br /> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188) <br /> at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210) <br /> at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174) <br /> at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) <br /> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) <br /> at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) <br /> at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151) <br /> at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:834) <br /> at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:640) <br /> at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1286) <br /> at java.lang.Thread.run(Thread.java:595) <br /> Caused by: java.lang.reflect.InvocationTargetException <br /> ... 23 more <br /> Caused by: net.jforum.exceptions.DatabaseException: java.sql.SQLException: SQL String can not be NULL <br /> at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:910) <br /> at com.mysql.jdbc.PreparedStatement.init(PreparedStatement.java:438) <br /> at com.mysql.jdbc.Connection.clientPrepareStatement(Connection.java:2138) <br /> at com.mysql.jdbc.Connection.clientPrepareStatement(Connection.java:2068) <br /> at com.mysql.jdbc.Connection.prepareStatement(Connection.java:4611) <br /> at com.mysql.jdbc.Connection.prepareStatement(Connection.java:4516) <br /> at com.mchange.v2.c3p0.impl.NewProxyConnection.prepareStatement(NewProxyConnection.java:190) <br /> at net.jforum.dao.generic.AutoKeys.executeAutoKeysQuery(AutoKeys.java:137) <br /> at net.jforum.dao.generic.AutoKeys.executeAutoKeysQuery(AutoKeys.java:118) <br /> at net.jforum.dao.generic.GenericTopicDAO.addNew(GenericTopicDAO.java:303) <br /> at net.jforum.view.forum.PostAction.insertSave(PostAction.java:1074) <br /> ... 23 more <br /> Caused by: java.sql.SQLException: SQL String can not be NULL <br /> ... 34 more <br /> <br /> END ERROR STACK TRACE-->

Any advice ?

Thanks.
[originally posted on jforum.net by altuga]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Problem is database. We solved it. Please adjust your database configuration carefully.

Thanks.
[originally posted on jforum.net by altuga]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: error while inserting new message and new user