This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem getting email/password from session

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Greetings - I am trying to integrate jforum into my own web site, using the sso login feature.

I set the following session variables in my login routine:
String password ="somepassword";
session.setAttribute("sso.password.attribute", password);
session.setAttribute("sso.email.attribute", "my@testemail.com");

After my login routine, I have a link to the jforum page.
Inside ControllerUtils.checkSSO(), the following statement return 'NULL' email and password values:
String email = (String) session.getAttribute(SystemGlobals.getValue(ConfigKeys.SSO_EMAIL_ATTRIBUTE));
String password = (String) session.getAttribute(SystemGlobals.getValue(ConfigKeys.SSO_PASSWORD_ATTRIBUTE));

--

I was wondering if jforum sets these to null sometime after I login using my routine, and checkSSO() is called?

Just wondering if anyone has run into that?

(Note: I can get other login objects I set at the same time )

Thanks for the help,
Curt
[originally posted on jforum.net by curtc]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic