This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes JForum and the fly likes Not Showing :8080, using Tomcat over Apache how? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Not Showing :8080, using Tomcat over Apache how?" Watch "Not Showing :8080, using Tomcat over Apache how?" New topic
Author

Not Showing :8080, using Tomcat over Apache how?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Cordial Greetings:

I want to set my forum for local net, wrrting in (my station o my pc) http://192.168.0.97/JSPForum/
and Not
http://192.168.0.97:8080/JSPForum
I'm using SuSE Linux 10.1
Apache Settings
My configurations Files
workers.properties

workers.tomcat_home=/usr/local/tomcat/
workers.java_home=$JAVA_HOME
ps=/
worker.list=default
worker.default.port=8009
worker.default.host=localhost
worker.default.type=ajp13
worker.default.lbfactor=1


httpd.conf
JkWorkersFile "conf/workers.properties"
JkLogFile "logs/mod_jk.log"
JkLogLevel warn
JkMount /JSPForum default
JkMount /JSPForum/* default

JkMount /*.jsp default


What I need to do?
What is my first page? index.jsp?

How to change this in index.htm or __index.redirect?


http://192.168.0.97:8080/JSPForum/forums/list.page

[originally posted on jforum.net by joseluisbz]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Configuring Apache HHTPD with Tomcat can be confusing the first time. It's best to try to break it down into sections.

First, get your application running under Tomcat via TC's HTTP service (e.g., the port 8080 URLs).

FYI, the error you're getting indicates a DB configuration problem. You may need to double check your jforum-custom.conf file settings.

OK, once it's running, you need to verify that your Tomcat config is set up correctly for AJP connections. The server.xml config file should have a "Connector" element with a protocol="AJP/1.3" defined on it.

If needed, restart Tomcat to make sure changes are being used.

Next, in the HTTPD config, you need to make sure that the jk_module mod is loaded via a "LoadModule jk_module modules/modjk.so" statement. (And that the mod library is available.

Then you need to add the Jk* statements (you're look fine), into the HTTPD config file(s). Note that if you have virtual servers defined, you may need to do this inside the virtual server definitions.

That should get you started. If you want a fancier setup, there is a Tomcat "Listener" class org.apache.jk.config.ApacheConfig that can be used to automatically create a set of Jk* HTTPD statements when TC starts. This will have all web applications included in it and can be "Included" into your HTTPD.conf file.
[originally posted on jforum.net by monroe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
there is other extension related with the JForum, like .page that i need to declarate or include?
For my Web aplication (foro), for no use http://192.168.0.97:8080/JSPForum
http://192.168.0.97/JSPForum/

jforum-custom.conf

#Installation specific configuration options
#Mon Jul 09 00:27:23 COT 2007
i18n.board.default=en_US
forum.link=http\://192.168.0.97\:8080/JSPForum/
#forum.link=http\://192.168.0.97/JSPForum/


database.support.autokeys=true
database.driver.name=mysql
database.connection.pool.timeout=5000
database.connection.dbname=JSPMySQL
installed=true
database.support.subqueries=true
dao.driver=net.jforum.dao.mysql.MysqlDataAccessDriver
#homepage.link=http\://192.168.0.97\:8080
homepage.link=http\://192.168.0.97


mysql.unicode=
database.connection.pool.min=5
database.connection.password=,mypass
database.connection.pool.max=10
user.hash.sequence=2b9daa88b3f0bb4a3418990231b29475
database.connection.username=joseluisbz
dbencoding=utf-8
database.connection.port=3306
dbunicode=true
database.connection.implementation=net.jforum.PooledConnection
database.connection.host=192.168.0.97
database.connection.driver=com.mysql.jdbc.Driver
database.connection.string=jdbc\:mysql\://${database.connection.host}\:${database.connection.port}/${database.connection.dbname}?user\=${database.connection.username}&password\=${database.connection.password}&autoReconnect\=true${mysql.unicode}${mysql.encoding}&useNewIO\=false&zeroDateTimeBehavior\=convertToNull&useServerPrepStmts\=false&dumpQueriesOnException\=true&jdbcCompliantTruncation\=false
mysql.encoding=



In server.xml

<Connector port="8009"
enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />


in httpd.conf
LoadModule jk_module modules/mod_jk-1.2.21-apache-2.2.x-linux-i686.so


Please Help me with that
[originally posted on jforum.net by joseluisbz]
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Not Showing :8080, using Tomcat over Apache how?
 
Similar Threads
javax.servlet.ServletException: Error allocating a servlet instance
page error 500 -- net.jforum.exceptions.DatabaseException
Unable to bootstrap JForum repository
after install using hsqldb - The database is already in use by another process
Export jforum project