• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

sso(my app) 1stuser login and logout and 2nduser login it show Connected users:1st userinfo,2nduser

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're getting a NPE because JForum uses ThreadLocal, so you will have to initialize JForumExecutionContext first. Take a look at JForum.java#service().

Also, for the logout process, see UserAction.java#logout(). Simple calling invalidate() will not be enough.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

i have written SSO for Single Sign On For my apllication login using Session it's working fine.

The problem is when
sso(my app) 1stuser login and logout and 2nd user login it show Connected users:1st login userinfo,2nd login userinfo

I have session expire when user click logout buttion.But it is not working

I worte following code for :

SessionContext session2 = JForumExecutionContext.getRequest).getSessionContext();
session2.invalidate();

i am getting NullPointer Exception


Any body help please.


Thank,
Gopal.G
[originally posted on jforum.net by gopal.g]
 
vaibhav hadole
Greenhorn
Posts: 4
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
have you find any solution to this ?

I am facing same problem... Plzz help!!!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic