wood burning stoves 2.0*
The moose likes JForum and the fly likes Installation of 2.1.8 version exception Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Installation of 2.1.8 version exception" Watch "Installation of 2.1.8 version exception" New topic
Author

Installation of 2.1.8 version exception

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I installed JForum 2.1.8 on jboss 3.2.3 where I have a working 2.1.7 installation but I get this error:


javax.servlet.ServletException: Servlet.init() for servlet jforum threw exception
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:963)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:668)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
......

java.lang.NoSuchMethodError: org.apache.lucene.index.IndexReader.indexExists(Ljava/lang/String;)Z
at net.jforum.search.LuceneSettings.useFSDirectory(LuceneSettings.java:80)
at net.jforum.search.LuceneManager.init(LuceneManager.java:77)
at net.jforum.search.SearchFacade.init(SearchFacade.java:84)
at net.jforum.ConfigLoader.startSearchIndexer(ConfigLoader.java:265)
at net.jforum.JForumBaseServlet.startApplication(JForumBaseServlet.java:92)
at net.jforum.JForum.init(JForum.java:92)
...

I checked the folders structure and their permission, is there somethings I can check?

TIA
MDT
[originally posted on jforum.net by radar]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Check for a dupicated Lucene version, either in WEB-INF/lib or in jboss' common libraries.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I didn't find duplicated lucene jars.
Colud it be something with jboss library?
I'm using j2sdk1.4.2_08 on Jboss 3.2.1

MDT
[originally posted on jforum.net by radar]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
This error occurs because, somewhere, there is another version of Lucene. JForum uses Lucene 2.x

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I installed in a dedicated tomcat 5.5 server with jre 1.5 and it works fine

MDT
[originally posted on jforum.net by radar]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Installation of 2.1.8 version exception