aspose file tools*
The moose likes JForum and the fly likes Create a new index from scratch with date Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Create a new index from scratch with date" Watch "Create a new index from scratch with date" New topic
Author

Create a new index from scratch with date

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

I tried to reindex everything using the recreate index from scratch and using the by date option and I keep getting this error on my console:

Exception in thread "Thread-19" net.jforum.exceptions.DatabaseException: java.sql.SQLException: ORA-00933: SQL com
mand not properly ended

at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:216)
at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java:799)
at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1037)
at oracle.jdbc.driver.T4CPreparedStatement.executeMaybeDescribe(T4CPreparedStatement.java:839)
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1132)
at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3316)
at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:3361)
at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeQuery(NewProxyPreparedStatement.java:76)
at net.jforum.dao.generic.GenericLuceneDAO.getPostIdByDate(GenericLuceneDAO.java:160)
at net.jforum.dao.generic.GenericLuceneDAO.firstPostIdByDate(GenericLuceneDAO.java:137)
at net.jforum.search.LuceneReindexer.reindex(LuceneReindexer.java:123)
at net.jforum.search.LuceneReindexer.access$000(LuceneReindexer.java:64)
at net.jforum.search.LuceneReindexer$1.run(LuceneReindexer.java:86)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.sql.SQLException: ORA-00933: SQL command not properly ended

... 18 more

Does anyone knows how to fix this?
[originally posted on jforum.net by nadjim]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello,
For oracle you need to modify Oracle.sql adding this code in the SearchModel section:



in the default sql file that query is for MySQL.

MDT
[originally posted on jforum.net by radar]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
nadjim wrote:Hi,

I tried to reindex everything


Hello!
Just upgraded from 2.1.6 to 2.1.8, and forum search works only for newly-created topics.

Does anyone know how to make jForum search in older topics too?

Thanks

upd: figured out, it's under "Lucene index" in admin panel.
[originally posted on jforum.net by n0mer]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Create a new index from scratch with date
 
Similar Threads
localized message is ORA-00942: table or view does not exist
Hibernate Criterion query: org.hibernate.exception.SQLGrammarException: could not execute query
hibernate exception SQLGrammarException could not fetch initial value for increment
Weblogic 8.1 SP5 server got shutdown due to Connection leak and java.lang.OutofMemory
DB error in servlet while inserting data