Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JRE and servlet container requirements?

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
While installation went well under Java 5 in a Servlet API 2.4 container, I was wondering if it was possible to run JForum using Java 1.4 and Servlets API 2.3? I found no mention of this in the forums or the installation page, except for a message from 2004 that Java 1.4 is required.
[originally posted on jforum.net by udittmer]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The build file in the source specifies 1.4 as the compiler version so Java 1.4 probably won't be an issue. However, I'm not sure that it's been compiled against the 2.3 API.

But I don't think there are any major underlying 2.4 dependencies... but a few new methods might have slipped in.

I'd suggest trying to build 2.1.8 from the source distro (or repository) with the 2.3 API jars to be sure.

FWIW, 3.0 WILL require 1.5 or higher... after all 1.4 was released almost 6 years ago. And now that Sun's loosened up on licensing, there are almost no legal or technical reasons not to have a new version....
[originally posted on jforum.net by monroe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the quick reply. It seems to work fine under Servlet API 2.3.
[originally posted on jforum.net by udittmer]
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic