aspose file tools*
The moose likes JForum and the fly likes jforum behind htacces unable to login Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "jforum behind htacces unable to login" Watch "jforum behind htacces unable to login" New topic
Author

jforum behind htacces unable to login

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello,

maybe someone has nearly the same configuration?

/forum is redirected by JkMount to a local tomcat (ajp13, port 8009)

Everything is fine but my users wants the hole forum protected (invisible for unknown users).

1. try:
+ A /forum folder on the webserver with a .htaccess
After login into the apache-folder i can access the forum.
But if i try the login into the forum the authentificatin fails.

2. try:
+ A protection by a tomcat <security-constraint>
The behavior the login into tomcat is ok, but the jforum login fails always.

I tryed also a proxyName and proxyPort entry for the Port 8009 connector without success.

<Connector port="8009" <br /> address="127.0.0.1" <br /> scheme="http" <br /> proxyName="<official apache url>" <br /> proxyPort="80" <br /> enableLookups="false" <br /> redirectPort="8443" <br /> protocol="AJP/1.3" />

Has anyone a tip for protecting the hole forum?

with best regards

[originally posted on jforum.net by humptydumpty1]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jforum behind htacces unable to login
 
Similar Threads
Simulate HTTPS in Tomcat connector or Apache config?
URL rewrite?
Servlets, Tomcat, and Apache, oh my!
Resolving website name correctly in Tomcat
Tomcat behind Apache with SSL terminated at firewall - share session between Tomcat connectors?