Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Quartz indexer

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I,m working with JForum for portlets dowloaded from Jahia cvs for Jahia.4.x. Also i have dowloaded an standalone version of JForum from this page, JForum 2.1.8.

I have released that the version of JForum used by Jahia is an old version by looking to the seacher clases. So i have made 2 versions of JForum given by Jahia. One is using the "Quartz" search and in the other i tried to implement the Lucene searcher.
I,m no been sucessfuly to index and search anything in any of them.

Problem with the version with "Quartz": it does load the SearchManager, but i dont see that it indexes. I have read issues on this page about the searcher but i dont understant why it doesnt index. It�s supose to index by itself.

Problem with the version with "Lucene" it says that its indexing and finished doing it but whe i enter an postId number, its says that the post is not indexed (In the Admin Pane). I have a list of all the class and pages i,ve changed it is usefull i can upload it in a future post.

Regards
[originally posted on jforum.net by pepe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi again,

I forgot to say that i,m using Tomcat 5.5.20 with Oracle9 database. And Jetspeed2 as portal application.

Regards
[originally posted on jforum.net by pepe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Quartz indexer is really old, we don't support it anymore. About lucene, how did you run the task? from one post id to another or from dates? I suggest you to use dates.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I tried with dates, and it seems to index.But i still not get result from the search. Wonder if i missed something. I had an sql error because of "LIMIT 1", i had to change the sql for Oracle



Regards
[originally posted on jforum.net by pepe]
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic