aspose file tools*
The moose likes JForum and the fly likes Initial Forum Group Priv settings ignored Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Initial Forum Group Priv settings ignored" Watch "Initial Forum Group Priv settings ignored" New topic
Author

Initial Forum Group Priv settings ignored

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm running 2.1.8. Here's my test case.

I examine all privileges for the Administration group.
I create a new forum, leaving the four selection lists in the Permissions section unchanged.
I then go back and examine all Administration group privs, noting differences.

I create another forum in same Category as last time, but this time selecting the Administration group from all four Permission list boxes.
I go back and examine all Administrative goup privs, noting differences.

The state changes are the same for these two tests. Checking Administration group in the Forum creation Permissions boxes has no effect at all.
[originally posted on jforum.net by blaine]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
as far as I know... as soon as you set priviledges when creating a forum, the administrative group will have no permissions to the forum at all anymore.

So it's a good practice to
1) create all required categories / forums
and
create all required groups
2) iterate over all groups and set the group permissions

This way you can make sure that admin has highest priviledges, and that anonymous users do have the level of access that you explicitely defined
[originally posted on jforum.net by Sid]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Sid wrote:as far as I know... as soon as you set priviledges when creating a forum, the administrative group will have no permissions to the forum at all anymore.


You're speaking of the Administration group as if it behaves differently from all others. I discussed the Administration group because it's the group that I happened to use in my test. I just verified that the other groups behave the same exact way.

What you say about default permissions after creating a forum is wrong. Of the 9 Forum-selection lists on the Permissions screen, 5 default to permissive for the new group (i.e. the selections don't change at all when new Forum is added).

So it's a good practice to
1) create all required categories / forums
and
create all required groups
2) iterate over all groups and set the group permissions

This way you can make sure that admin has highest priviledges, and that anonymous users do have the level of access that you explicitely defined


I already figured that out. The point of this Topic isn't that I can't figure out how to accomplish a goal (wouldn't have posted to this Forum for that). It's that the four Permission checkboxes on the Forum creation screen have absolutely no effect. Write a test case where any of those lists has an effect and I'll withdraw my assertion that it's a bug.
[originally posted on jforum.net by blaine]
 
jQuery in Action, 2nd edition
 
subject: Initial Forum Group Priv settings ignored