This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JForum and the fly likes Deploying new SSO class Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Deploying new SSO class" Watch "Deploying new SSO class" New topic
Author

Deploying new SSO class

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,
I inserted the sso.jar file, mentioned in the previous message, in the directory Tomcat 5.5\webapps\jforum-2.1.8\WEB-INF\lib. Then I've modified the SystemGlobal.properties file in this way:



Where the class net.jforum.sso.ModifiedRemoteUserSSO is contained in the sso.jar file.
When I try to access to jforum I receive this error message:


An error has occurred.

For detailed error information, please see the HTML source code, and contact the forum Administrator.

Error while executing SSO actions: java.lang.ClassNotFoundException: net.jforum.sso.ModifiedRemoteUserSSO


Why?
Morover I've still the doubts of the previous message.
Could someone help me?
Thanks, bye bye.
[originally posted on jforum.net by abdujaparov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Try adding the classes in the correct package structure directly to WEB-INF/classes and see if it works.

Rafael
[originally posted on jforum.net by Rafael Steil]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi everybody,
I've written a my class for the sso authentication and now I would like test it. I've exported my eclipse project in a jar file named sso.jar, where must I put this jar in jforum to use my sso class?
The class use the hibernate library to access to the db of jforum where must I put the hibernate library?
Thanks a lot, bye bye.
[originally posted on jforum.net by abdujaparov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi Rafael,
I've put the class in WEB-INF/classes now I receive this error:


I think that the problem is the absence of some classes in particular the line 30 of my ModifiedRemoteUserSSO is:

This class is present in the jar file of my eclipse project (I've exported the project in a jar file) that I've put in jforum-2.1.8\WEB-INF\lib. This class then calls classes of the hibernate library where must I put the hibernate library?

Another question, when the user I return is NULL should jforum redirect me to the address defined here:
sso.redirect = www.google.it?
Thanks a lot, bye bye.
[originally posted on jforum.net by abdujaparov]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
When using SSO, the sso.redirect key is used to redirect the user to your login page.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deploying new SSO class
 
Similar Threads
Steps to integrate JForum with your web application.
When will 2.1.5 be relased?
JForum 2.1.8 relesead
Some doubts about sso integration
SSO with JForum 2.1.7, Help!