my dog learned polymorphism*
The moose likes JForum and the fly likes JForum 3 Initial Install - How to complete setup? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » JForum
Bookmark "JForum 3 Initial Install - How to complete setup?" Watch "JForum 3 Initial Install - How to complete setup?" New topic
Author

JForum 3 Initial Install - How to complete setup?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I've pulled the latest rev of JForum3 from the SVN.

I followed the setup instructions and set up the database.

When I run JForum, I get to the main list page, but no forums are shown. I logged in as "admin" and proceeded to create a new category and forum, and still cannot see anything on the main page.

I looked at the jsp file, and found that there are some role associations which it looked like needed to be installed. I found that they are commented out in the data dump script, so I uncommented them and added them to the db. Still no change.

So I enabled all permissions in the dump script except for anonymous, still no change.

What am I missing here?

I am going to continue to debug to find the answer but if somebody can shed some light on this I'd appreciate it.

I am running on Tomcat 6 with JDK 6.


[originally posted on jforum.net by Zinger]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I've only worked with 2.1.8 so far, but there was an issue there too.

If you've set up a new forum/categorie and modified permissions there, administrator did have no priviledges on it, hence the admin didnt see a dime.

You might want to check the permissions page for the admin and validate that he has access to all forums ...
[originally posted on jforum.net by Sid]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks Sid, you got me a little bit closer.

I created "Category 1" and put "Forum 1" in it. I now see them listed on the main page. When I click on "Forum 1" I get a hibernate error.

I also get hibernate errors when I click on "Read New Messages Since Last visit", and it looks like the same error. Something about a column not existing. I'll figure it out eventually.

The exception:

SEVERE: Servlet.service() for servlet jforum threw exception
com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'post1_.post_subject' in 'field list'

I'm new to Hibernate, but basically the result query is trying to source a column that doesn't exist in the target table.


[originally posted on jforum.net by Zinger]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Ok, here's the deal.

The exception is being generated because the generated query is looking for the column "post_subject" on the table "jforum_posts". The problem is that this column is not on that table. It IS on a table named "jforum_posts_text", but there are no configured references to this table in the source code.

The entity net.jforum.entities.Post is the Hibernate link to the jforum_posts table. The problem is that this entity has the follow configuration in it that is causing the problem:

@Column(name = "post_subject")
@Field(store = Store.NO, index = Index.TOKENIZED)
private String subject;

I can find zero references anywhere in the project to the jforum_posts_text table, which has the post_subject column on it.

I am kind of confused here. Rafael stated in another thread that he felt Jforum3 was ready for public Beta, and it very well may be, but something is amiss in the version of the source that is available on the SVN. There is no way you can even get into the first forum you create because of this Hibernate configuration as it stands. The way I see it one of two things is wrong here:

1. The entity info for jforum_posts and jforum_posts_text are not deployed to the SVN.
2. The database has been updated and the latest model is not in the initial config script.

A distant 3rd possibility: none of this stuff has been tested yet and is just bug ridden.

Rafael if you see this post can you please comment? I was ready to commit to JForum3 since you said it was basically in beta at this point, but the problems I'm seeing are leading me to believe it's more in an alpha state.
[originally posted on jforum.net by Zinger]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JForum 3 Initial Install - How to complete setup?