File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JForum and the fly likes LastPostInfo is null on forum list Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "LastPostInfo is null on forum list" Watch "LastPostInfo is null on forum list" New topic
Author

LastPostInfo is null on forum list

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
See here for the full story, but basically I'm trying to replace the username with a Firstname/Lastname, which I just stuck in an extra field for now rather than re-do the schema. Anyhow, to make the info show up on the forums list, I had to extend ForumAction and add some functionality to retrieve the user ID from the LastPostInfo of each Forum.

The problem is when I first start up JForum, this information always seems to be null. Each request I send seems to fill in 1 forum's LPI, so say I have 5 forums. When I first load it up, all the information is missing. When I refresh, the first forum has its information, and so on, and the forum looks as it should after 5 refreshes. So I have a workaround for now, clearly, but I cannot determine why this information is null at first, and what causes it to be loaded.

For reference, here is my code overriding net.jforum.view.forum.ForumAction#list:


Any ideas?
[originally posted on jforum.net by msernatinger]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: LastPostInfo is null on forum list
 
Similar Threads
topics pagination is incorrect, maybe a bug
problems in the list of categories and forums
Customisation/Feature Request List
Complete separation of users groups and categories?
Spring DAO: When and Where to catch/throw exceptions