This week's book giveaway is in the Performance forum.
We're giving away four copies of The Java Performance Companion and have Charlie Hunt, Monica Beckwith, Poonam Parhar, & Bengt Rutisson on-line!
See this thread for details.
Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Quick reply does not work - java.lang.ClassCastException: java.util.ArrayList

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

i have tried integrating jforum with my webapp without SSO mech. Everything works fine except when i click on the quickreply tab
i get the error ( stack trace from the html file source code
java.lang.ClassCastException: java.util.ArrayList



it seems that that the app is not able to get the getparameter fom the webrequestcontext object

any help will be appreciated

[originally posted on jforum.net by anilhk]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
pls .. any help !!
[originally posted on jforum.net by anilhk]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Details on what you mean the statement below would be helpful. Especially, the "WITHOUT SSO" part.


i have tried integrating jforum with my webapp without SSO mech.


FWIW, this classCastException can occur if the URL contains duplicate parameters. E.g. ?x=2&x=3, which is valid in HTML (radio buttons use this). The URL parser converts them to from a single string value to an ArrayList... but if the code expect a single value then you get this error.

It might also be related to a bug in the code that causes this if the *.page URL is not a valid. See:

http://www.jforum.net/posts/preList/4885/19661.page


[originally posted on jforum.net by monroe]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic