aspose file tools*
The moose likes JForum and the fly likes Smilies WERE working fine (2.1.8) NOW: Just printing full html escaped Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Smilies WERE working fine (2.1.8) NOW: Just printing full html escaped" Watch "Smilies WERE working fine (2.1.8) NOW: Just printing full html escaped" New topic
Author

Smilies WERE working fine (2.1.8) NOW: Just printing full html escaped

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Smilies were working fine (despite having this issue of having to remove the / from #CONTEXT# in the database)

Suddenly, without changing anything, the html is being escaped.

I'd also seen a bug in the code where < is escaped to &lt NOT &lt; (downloaded code version)

Why would the smilies suddenly be escaping their output!!!?!/1/1/??!?!/1/1/13/243

I didn't change anything... :///////////
[originally posted on jforum.net by jforumapp]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
CRAZY UPDATE!!

First, My other email about ??? in emails, set type to html, now it emails html code, but with wrong mime type, but at least the right encoding! Emails contain utf-8 chars, but also <htmltags>

Also, when I type ampersand-a-m-p-semicolon I should see ampersand-a-m-p-semicolon shouldn't I? In reality, it doesn't escape escape codes... so I can type & which is cool, but means to type ampersand-l-t-semicolon I need to type ampersand-a-m-p-semicolon-l-t-semicolon, giving &lt; versus <

AAaaaanyway, stay on topic.

So big update, I've found that smilies are technically working, and HTML is enabled for groups, except... EVERY single user now has html enabled set to false...

HOW is that possible?

Is there a code that updates all users and sets html enabled to false?

I will sql all users back to html enabled true, JUST to fix the smilies, which BTW, are NOT html.

Oh, yeah sure, the 'technology' that displays them is html, but, html is when you want to use HTML in a post.

HTML is not when you want to use smilies.

HTML, smilies, BBCode, markdown, foobar, lolcode, all of these are seperate, no matter what presentation technology is used to display them

SMILIES SHOULD NOT BE CONTROLLED WITH THE HTML FLAG

Html tags should be CONTROLLED with the HTML tag, NOT smilies :roll: :roll: :roll: :roll: :roll: :roll:

Unless I am totally off base, but hey, I am sleep deprived to heck and there is a mosquito in this damn room, and you've seen the prelude intro to fight club where he has insomnia an he is losing his mind?

It is like that, but trying to code at the same time. (this jforum is just a side project that I am setting up, so I am not really giving it my full attention...)
[originally posted on jforum.net by jforumapp]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Smilies WERE working fine (2.1.8) NOW: Just printing full html escaped