aspose file tools*
The moose likes JForum and the fly likes Export jforum project Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Export jforum project" Watch "Export jforum project" New topic
Author

Export jforum project

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

I have my jforum project and i want to host it on another distant server
so i have copied the jforum folder contained in the webapps of my tomcat to the webapps of the other server
and i have copied the database folder jforum from wamp/bin/mysql/data to the wamp of the other server
but it doesn't work here is the stack trace of the exception throwed by the server:


what should i do, is there another way to export a jforum project?
thanks for helping
[originally posted on jforum.net by walido]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
The basic problem seems to be connecting to your database server.

I don't think that a MySQL database and user information can be copied by just moving the Data directory. Maybe it can, but that doesn't seem like a good way to do it. Especially if there is ANY version or patch differences between the systems.

Can you verify that your jforum database and information is available on the remote server? E.g., thru command line mysql calls or web admin tools (like PhPMySQLAdmin).

It could be a problem with database user id not being allowed to connect from the application server as well. MySQL is picky about such things.

You might also need to check that the DB connection URL in your jforum-custom.conf file is what is needed on the remote server. E.g., if the MySQL server is on a different machine or port.
[originally posted on jforum.net by monroe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thanks it's done
that exception was throwed because of the export of the DB the tables was incomplete ,so i tried to do the export by script not by copying and it worked just fine
Thanks monroe you have been a great help
[originally posted on jforum.net by walido]
Nancy James
Greenhorn

Joined: Oct 23, 2014
Posts: 6
Hi,
I have the same Database problem with Jforum. Am using struts2 application. Am not sure about jforum-custom.config file. i don know what to put in that file. I checked mysql.properties username and password. Do i want to change anything in SystemGlobals. properties file?
Also while starting Tomcat server i got the following error message:
java.lang.Exception: Could not load com/mysql/jdbc/ResultSet.class
at com.opensymphony.xwork2.util.finder.ClassFinder.readClassDef(ClassFinder.java:745)
at com.opensymphony.xwork2.util.finder.ClassFinder.access$400(ClassFinder.java:57)
at com.opensymphony.xwork2.util.finder.ClassFinder$InfoBuildingVisitor.extractSuperInterfaces(ClassFinder.java:790)
at com.opensymphony.xwork2.util.finder.ClassFinder$InfoBuildingVisitor.visit(ClassFinder.java:777)
at org.objectweb.asm.xwork.ClassReader.accept(Unknown Source)
at org.objectweb.asm.xwork.ClassReader.accept(Unknown Source)
at com.opensymphony.xwork2.util.finder.ClassFinder.readClassDef(ClassFinder.java:740)
at com.opensymphony.xwork2.util.finder.ClassFinder.<init>(ClassFinder.java:148)
at org.apache.struts2.convention.PackageBasedActionConfigBuilder.findActions(PackageBasedActionConfigBuilder.java:295)
at org.apache.struts2.convention.PackageBasedActionConfigBuilder.buildActionConfigs(PackageBasedActionConfigBuilder.java:277)
at org.apache.struts2.convention.ClasspathPackageProvider.loadPackages(ClasspathPackageProvider.java:52)
at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:200)
at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:55)
at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:360)
at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:403)
at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:69)
at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:48)
at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:298)
at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:119)
at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4076)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4730)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:822)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
at org.apache.catalina.core.StandardService.start(StandardService.java:525)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

Please help . Am working it for 3 days more....
 
wood burning stoves
 
subject: Export jforum project