wood burning stoves 2.0*
The moose likes JForum and the fly likes Deploying Jforum in weblogic 8.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Deploying Jforum in weblogic 8.1" Watch "Deploying Jforum in weblogic 8.1" New topic
Author

Deploying Jforum in weblogic 8.1

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
One quick thought.. are you running this directly from a war file? jForum (and, it think, Freemarker) requires a physical webapp directory.

I would also guess that something is very non-standard about your Weblogic setup. The Null value is probably the result of a "getRealPath" call. I beleive that the standards say that even if you're running from a war, you should get URL Resource path for this call.
[originally posted on jforum.net by monroe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I can able to deploy jfourm in weblogic 8.1 but I was not able to run the application some exception is thrown in the console

Error is shown below
Please help me


log4j:ERROR Could not open [null/WEB-INF/log4j.xml].
java.io.FileNotFoundException: null\WEB-INF\log4j.xml
(The system cannot find th
e path specified)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java
:583)
at org.apache.log4j.xml.DOMConfigurator.configure(DOMConfigurator.java:6
87)
at net.jforum.JForumBaseServlet.init(JForumBaseServlet.java:104)
at net.jforum.JForum.init(JForum.java:94)
at weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(Servl
etStubImpl.java:1028)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
121)
at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
pl.java:904)
at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
Impl.java:883)
at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
mpl.java:822)
at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
java:535)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:373)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:28)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.ja
va:27)
at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(Clickst
reamFilter.java:59)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.ja
va:27)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio
n.run(WebAppServletContext.java:6724)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
121)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppSe
rvletContext.java:3764)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestIm
pl.java:2644)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
<Feb 6, 2009 3:48:42 PM IST> <Error> <HTTP> <BEA-101017> <[ServletContext(id=846
0967,name=jforum,context-path=/jforum)] Root cause of ServletException.
net.jforum.exceptions.ForumStartupException: Error while starting JForum
at java.util.Hashtable.put(Hashtable.java:393)
at net.jforum.util.preferences.SystemGlobals.buildSystem(SystemGlobals.j
ava:116)
at net.jforum.util.preferences.SystemGlobals.initGlobals(SystemGlobals.j
ava:104)
at net.jforum.ConfigLoader.startSystemglobals(ConfigLoader.java:90)
at net.jforum.JForumBaseServlet.init(JForumBaseServlet.java:108)
at net.jforum.JForum.init(JForum.java:94)
at weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(Servl
etStubImpl.java:1028)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
121)
at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
pl.java:904)
at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
Impl.java:883)
at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
mpl.java:822)
at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
java:535)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:373)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:28)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.ja
va:27)
at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(Clickst
reamFilter.java:59)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.ja
va:27)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio
n.run(WebAppServletContext.java:6724)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
121)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppSe
rvletContext.java:3764)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestIm
pl.java:2644)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
Caused by: java.lang.NullPointerException
... 25 more
[originally posted on jforum.net by rb68626]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
monroe wrote:jForum (and, it think, Freemarker) requires a physical webapp directory.

In FreeMarker, this depends entirely on what template loader you use. I.e. WebappTemplateLoader uses ServletContext.getResource(), so it works from WAR files too.

(Actually, it will first try getRealPath() to bypass servlet container resource caches, but if it gets null from it, it'll fall back to using ServletContext.getResource())
[originally posted on jforum.net by aszegedi]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deploying Jforum in weblogic 8.1
 
Similar Threads
java.net.NoRouteToHostException: No route to host: connect
NoClassDefFoundError problem
Read timed out Exception - weblogic 8.1 sp6
NoClassDefFoundError problem
On weblogic server,IntrospectionException.