Meaningless Drivel is fun!*
The moose likes JForum and the fly likes Web administrative tool for reindexing posts is broken Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Web administrative tool for reindexing posts is broken" Watch "Web administrative tool for reindexing posts is broken" New topic
Author

Web administrative tool for reindexing posts is broken

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I've just started out learning JForum, and I've been playing around with the administrative interface, and I've noticed that part of the Administrative interface doesn't work. If you delete the indexes, or they become corrupted in any way, you would expect the admin panel to allow you to regenerate the entire index from the posts stored in the database. When you run the reindexing job in these circumstances, it appears to finish without any problems, and yet when you run a search, you get no results. At the very least it should tell you how many posts were reindexed - or give you some form of error message.

So I had a look at the code, and have found out what the problem is. Here is the class in question (I think)..



The problem appears to be that this class loads the messages out of the index in order to reindex them. This doesn't make any sense if the index has been moved, lost or corrupted - what it should do is load the posts from the database before reindexing them.

I was wondering if anybody knew why this class functions in the way that it does? I'm going to modify it myself, locally, so it loads the posts from the DB, and so it provides a bit more debugging information; but if theres something I've missed, or misunderstood then this could be wasted effort.

Thanks
[originally posted on jforum.net by jsp1611]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I can't remember all the details but I know that there have been various problems with the Lucene indexing that was first released in 2.1.8. I know that there are various threads and fixes suggested by Raphael (the main Jforum programmer) in the forums somewhere.
[originally posted on jforum.net by monroe]
 
 
subject: Web administrative tool for reindexing posts is broken
 
Similar Threads
search content in a file , file search
Countdown timer in java
0 hits while using pharsequery
Lucene beginner question
Reindex