This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JForum and the fly likes Disable private messages? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Disable private messages?" Watch "Disable private messages?" New topic
Author

Disable private messages?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hi,

First of all, a big thanks to the developers of this wonderful tool. I am a librarian and we use this tool for book discussions in a mentoring program. If it is possible, I would like to find a way to disable the private messages function in our forum, since we don't want the students doing anything but public comments on the particular discussion topic. I have looked at the admin pages but can't discover if there is some setting that would do this for us.

Thank you in advance for your help with this.

Sara
[originally posted on jforum.net by saoyama]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
There is no configuration setting to turn this off. There are various ways to manually disable this.

One is that you can edit the template files to remove all PM references.

Another way is to just leave the PM links but modify the templatesMapping.properties file to change the pm.sendform value to use a new template file that says "This function not available". (Note: The default is to share the same form used for making posts so you can't just change the template).

Both of these are sort of "security by obscurity" methods. If you need to ensure this doesn't work and are familiar with Java coding, you can look at the PrivateMessageAction class and make sure it doesn't work here. The quick way is to make the sendSave method return a "Function not available" page.
[originally posted on jforum.net by monroe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Thank you so much. This is very helpful and should solve our problems!

Sara
[originally posted on jforum.net by saoyama]
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Disable private messages?
 
Similar Threads
Private messages on Javaranch . . .
Disable stderr messages in weblogic
Is JForum application support these features?
Is it possible to disable / use settings for private messaging
RFE: do not allow HTML in messages