aspose file tools*
The moose likes JForum and the fly likes Private message count not filled in when using SSO Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "Private message count not filled in when using SSO" Watch "Private message count not filled in when using SSO" New topic
Author

Private message count not filled in when using SSO

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
When logging in using SSO the jforum code uses



instead of



to get the User object. (called from SSOUtils.userExists, ControllerUtils.refreshSession)

selectByName does not fill in the private message count



and therefore the text 'New Private Messages: (X)' does not show up in the forum header.

(note that it also doesn't get the user groups, is that bad?)

Can this be fixed?
[originally posted on jforum.net by jrouwe]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I've hacked GenericUserDAO:



(see added comments)

This fixes the bug. It would be nice if this was fixed in a general release too.

(note that I hacked the SQL string straight into the code, but it needs to be changed in the generic_queries.sql file)
[originally posted on jforum.net by jrouwe]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Private message count not filled in when using SSO