aspose file tools*
The moose likes JForum and the fly likes How the heck do I install? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "How the heck do I install?" Watch "How the heck do I install?" New topic
Author

How the heck do I install?

Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
:?
I'm so lost, can someone please help me step by step?

BTW, I'm on a Mac.
[originally posted on jforum.net by Lawlertend]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Which step are you stuck on? What's on the screen in front of you?
[originally posted on jforum.net by boyarsky]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
I'm stuck at the step where you click this link:
http://localhost:8080/jforum/

When I click it, it doesn't work?
[originally posted on jforum.net by Lawlertend]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
after deploy-ing into /webapps directopry of tomcat,
you shoud access
http://localhost:8080/jforum/install.jsp
(assuming you unzipped jforum-2.1.8 info jforum)

[originally posted on jforum.net by mosu]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
When I click on that link, it says it can't connect to the server.
[originally posted on jforum.net by Lawlertend]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
did you START the damn server or not?! is it configured to work on 8080? Default aopache tomcat starts on 8080...

What have you done after all?

[originally posted on jforum.net by mosu]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
the first question should be: do you have an application server (servlet container) installed - like tomcat?

How do you run this server? is it installed as "service" - that is does it get inited whenever you start your machine - or do you have to run the start.sh manually?

Just cause there's a "link" mentioned doesnt mean you can access it right away. The link for localhost means that there should be some webserver listening on that machine - so you first have to make sure it runs.

So what next if the tomcat is running? Deploy the file within the webapps directory, e.g. unzip it there... so that there's something like jforum-2.1.8/<actual files and folders> as subfolder of webapps...

Just to be sure you then could restart the application server (tomcat) so that the app gets properly loaded. Then you can finally click the link (easy huh? :-)) ... and if there's error messages displaying instead of a page you'd expect - check out the log files ...

Logs are the tomcat admin's best friend ;)
[originally posted on jforum.net by Sid]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Testing
[originally posted on jforum.net by anver]
Migrated From Jforum.net
Ranch Hand

Joined: Apr 22, 2012
Posts: 17424
Hello Everyone,

Could anyone plz tell me how to configure Jforum with the Apache Tomcat 6?

I have installed the apache tomcat and then unzip the Jforum file and copied it to the directory named "C:\Apache\webapps" (If I am not mistaken this is what was suppose to be done) and then I startup the Apache Tomcat server and wrote "http://localhost:8080/Jforum" in the web browser but it didn't work. I get the following page on my browser, please help me to correct this or give me step by step instructions to register the JForum application within Tomcat:

-----------------------------------------------------
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet.init() for servlet jforum threw exception
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

net.jforum.exceptions.DatabaseException: Error while trying to start the database: net.jforum.exceptions.DatabaseException: java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:468)
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:78)
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

net.jforum.exceptions.DatabaseException: java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:468)
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:78)
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

java.sql.SQLException: An attempt by a client to checkout a Connection has timed out.
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:65)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:468)
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:78)
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


root cause

com.mchange.v2.resourcepool.TimeoutException: The pool timed out while waiting to acquire a resource -- timeout at awaitAvailable()
com.mchange.v2.resourcepool.BasicResourcePool.awaitAvailable(BasicResourcePool.java:1157)
com.mchange.v2.resourcepool.BasicResourcePool.prelimCheckoutResource(BasicResourcePool.java:405)
com.mchange.v2.resourcepool.BasicResourcePool.checkoutResource(BasicResourcePool.java:351)
com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:466)
com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource.getConnection(AbstractPoolBackedDataSource.java:125)
net.jforum.C3P0PooledConnection.getConnection(C3P0PooledConnection.java:137)
net.jforum.ForumStartup.startDatabase(ForumStartup.java:78)
net.jforum.JForum.init(JForum.java:95)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
java.lang.Thread.run(Thread.java:619)


note The full stack trace of the root cause is available in the Apache Tomcat/6.0.20 logs.


--------------------------------------------------------------------------------

Apache Tomcat/6.0.20
[originally posted on jforum.net by deepakarora01]
 
Consider Paul's rocket mass heater.
 
subject: How the heck do I install?