File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Distributed Java and the fly likes MQ v7 with jdk 1.4.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "MQ v7 with jdk 1.4.2" Watch "MQ v7 with jdk 1.4.2" New topic
Author

MQ v7 with jdk 1.4.2

Neeraj Dheer
Ranch Hand

Joined: Mar 30, 2005
Posts: 225
Hi,

We are in the midst of upgrading from IBM MQ v6 to IBM MQ v7. We have a mix of JMS-based and IBM MQ-API based applications. However the applications still use jdk 1.4.2 - Upgrading the jdk is not an option at the moment. I have checked the pre-requisites at the IBM MQ site, and MQ v7 (specifically 7.0.1.3) shoould work with java 1.4.2

IBM MQ Prerequisite site: http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg27011929

For the upgrade, we also upgraded the client jar files from MQ v6 to MQ v7 client jars - We always use the CLIENT mode for connections.
All the point-to-point connections were migrated successfully - Did not come across any issue with either the client v7 jars - in both IBM MQ and JMS mode - and both with and without JNDI bindings.

However, we need to connect to a topic still on MQ v6 using the same MQ v7 jar files. The issue we are facing is that the connection is made fine (Using JNDI bindings files generated by the JMSAdmin utility using v7 jars). We also receive messages, however after receiving a few (random) number of messages, we get the following error and the connection drops:
Message : javax.jms.JMSException: MQJMS1107: A problem with the connection has occurred.

After enabling JMS Trace for this process, we see the following 2 issues:

1. See the following messages:





and then the second set of error messages:

2.


now, my questions:
1. Do we really need the mqjbnd.dll file (So dll on my local windows development environment and the Linux library on the Linux env?) ? If we do, why did we not see the error earlier for point-to-point?

2. Since we are using jdk 1.4.2, the java.lang.management.ManagementFactory class obviously cannot be found - which does mean that we might be using the jdk 5 version of the client jars rather than the jdk 1.4.2 version - However again, why did it work so far? Also, I did try to find the MQ v7 jdk 1.4.2 client jars but could not - Would highly appreciate if someone could point me to a download link.

3. Is there any way to get the JMX package for jdk 1.4.2?

The entire jms trace file is very big but can attached the relevant bit if needed.

Thanks!


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: MQ v7 with jdk 1.4.2