Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Question regarding servlet repeating a parameter value when it gets displayed on the xml page.

 
Michele Smith
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a servlet which is doing its job. Only thing is I need to repeat a parameter value on the xml page as a blue hyperlink.

The value to get passed is AV_FILE from the below code.

Can you think of a way to do this?

Lemme know, thanks,
============================
 
Greg Charles
Sheriff
Posts: 2985
12
Firefox Browser IntelliJ IDE Java Mac Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Let me understand what you're doing. You build up an XML document, then immediately apply an XSL transformation to convert it to HTML. Now you want something in the HTML to become a hyperlink. The AV_FILE parameter is telling you where the hyperlink should go, but I don't see anything that shows you the target of that link. My best guess of what you want to do is set an attribute in your XML showing that the element should be rendered in HTML as a link, and then modify your XSL to render it that way.
 
Michele Smith
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for responding and sorry for the delay!

Well after doing a little research, this code in the first posting generates the xml page all by itself.

What I was wanting to to was to take the RParameters.AV_FILE

and somehow hook it onto the xml page through the servlet to have it also output a blue hyperlinked area of text which would contain only the RParameters.AV_FILE, which can be either a file name or a URL.

Thanks,
 
Michele Smith
Ranch Hand
Posts: 421
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello still working on this one. I did a little research on xmlns and inserted some code. Only thing is it isn't working. I have never worked with xmlns before. What it does is it outputs the whole line:
xmlns:xlink="AdditionalOfferingsVideo/xlink"

and I want it to just display the name of the file or the video from the RParameters.AV_FILE entry.

Do you have any ideas on how I can get it to recognize this parameter and use the xmlns to get a hyperlink on the xml page?

--Thanks!



 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic