wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes How to deploy open cms on jboss as 7 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "How to deploy open cms on jboss as 7" Watch "How to deploy open cms on jboss as 7" New topic
Author

How to deploy open cms on jboss as 7

Avneesh Sisodia
Greenhorn

Joined: Apr 24, 2012
Posts: 11

Hello everyone,
I want to install open cms using JBoss AS 7.x. I read so many blogs and answers of related questions, but i didn't get right way to do this. please help me ..
I am using jdk1.6 on windows OS.
Thanks
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9955
    
163

What problems are you running into while deploying the application and which exact AS7 version are you using?

[My Blog] [JavaRanch Journal]
Avneesh Sisodia
Greenhorn

Joined: Apr 24, 2012
Posts: 11

I am using jboss-as-web-7.0.0.Final. I am trying to deploy opencms_8.0.4 war file into jboss manually. I mean i am putting war into ..\standalone\deployments location in JBoss and starting server . It gives so many error and not able to deploy war.
Please tell me complete steps that how I can deploy and run it.
Tim Moores
Rancher

Joined: Sep 21, 2011
Posts: 2408
Has it occurred to you to analyze what kind of errors you're getting? If not, the second best approach would be to post them here (meaningful excerpts only, of course).
Avneesh Sisodia
Greenhorn

Joined: Apr 24, 2012
Posts: 11

it shows..

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9955
    
163

The first thing I would suggest is to use the latest released 7.1.1.Final instead of 7.0.x. Deploy it there and if it fails there too, post the relevant logs.
Avneesh Sisodia
Greenhorn

Joined: Apr 24, 2012
Posts: 11

it showing same error in JBoss 7.1.1

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9955
    
163

Avneesh Sisodia wrote:it showing same error in JBoss 7.1.1


That's not the same error. It's different.

It looks like the application is using OpenJPA persistence provider. There's this thread in the AS7 forum which explains how to integrate OpenJPA in AS7, but if you want the exact steps on how to do it with Open CMS application, then you'll have to check their documentation or ask in their forums.
Avneesh Sisodia
Greenhorn

Joined: Apr 24, 2012
Posts: 11

I tried many times to get help from opencms forum but i failed every time.. That's why I put my question here..
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: How to deploy open cms on jboss as 7
 
Similar Threads
Comparison b/w Apache Lenya and Alfreso
CMS For Portals
content management system
Content Management System(CMS) in Struts 2.
JBOSS CMS opening txt Files