aspose file tools*
The moose likes Security and the fly likes JAAS LoginModule with WebSphere Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Security
Bookmark "JAAS LoginModule with WebSphere "unable to find LoginModule class"" Watch "JAAS LoginModule with WebSphere "unable to find LoginModule class"" New topic
Author

JAAS LoginModule with WebSphere "unable to find LoginModule class"

D Arnott
Greenhorn

Joined: Oct 13, 2011
Posts: 7
Hey all,

I am having an issue I thought someone here might be able to help me with. I am not familiar with JAAS, but in setting up an environment to do some API work I ran into an issue getting the code to login properly. It throws an exception during runtime. I have the configuration file defined and it seems to be reading it, but it says I am missing a class. I have no idea what class/jar I would be missing. Any help would be greatly appreciated. Thanks!

EXCEPTION
javax.security.auth.login.LoginException: unable to find LoginModule class: com.ibm.ws.security.common.auth.module.proxy.WSLoginModuleProxy


jaas.conf file contents:

WSLogin {
com.ibm.ws.security.common.auth.module.proxy.WSLoginModuleProxy required delegate=com.ibm.ws.security.common.auth.module.WSLoginModuleImpl;
};

ITIM {
com.ibm.ws.security.common.auth.module.proxy.WSLoginModuleProxy required delegate=com.ibm.itim.apps.jaas.spi.PlatformLoginModule;
};
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JAAS LoginModule with WebSphere "unable to find LoginModule class"