File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Struts and the fly likes Is Struts 1.2.9 Struts1 or Struts2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Is Struts 1.2.9 Struts1 or Struts2" Watch "Is Struts 1.2.9 Struts1 or Struts2" New topic

Is Struts 1.2.9 Struts1 or Struts2

Gowher Naik
Ranch Hand

Joined: Feb 07, 2005
Posts: 643
i am using netbeans5.5 which supports struts 1.2.9.
I want to know is Struts 1.2.9 Struts1 or Struts2?

Joe Ess

Joined: Oct 29, 2001
Posts: 9168

Struts 1 versions start with 1 (i.e. 1.2.9).
Struts 2 versions start with 2 (i.e. 2.0.11)

[How To Ask Questions On JavaRanch]
Merrill Higginson
Ranch Hand

Joined: Feb 15, 2005
Posts: 4864
One more thing you should be aware of is that you can still develop for any release of Struts 2 using NetBeans 5.5. Just unzip the struts-blank-2.0.x.war file that comes with the download into a folder and make that folder your NetBeans project folder.
[ March 07, 2008: Message edited by: Merrill Higginson ]

Consultant, Sima Solutions
I agree. Here's the link:
subject: Is Struts 1.2.9 Struts1 or Struts2
It's not a secret anymore!