This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JForum and the fly likes JForum Manual Database Setup Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "JForum Manual Database Setup" Watch "JForum Manual Database Setup" New topic
Author

JForum Manual Database Setup

sasikanth ravipudi
Greenhorn

Joined: Apr 04, 2012
Posts: 13
Hi,
I had installed JForum successfully,my requirement is ,when ever i deploy war file of JForum into the server....it is asking install page (for every time war is deployed in server)..if we go for install database is recreated and all the data is getting lose..

How to skip this install.jsp
reply me please
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30123
    
150

Are you going to the install page or is it redirecting you there?

One thing we did here was to take the precaution here of deleting the jsp so it's not in the war to be run.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
sasikanth ravipudi
Greenhorn

Joined: Apr 04, 2012
Posts: 13
Thanks for replying Jeanne,its redirecting me to the install.jsp page
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30123
    
150

There's a property file that stores settings once you've installed. (jforum-custom.conf). Is it possible this file is getting overridden when you deploy?
sasikanth ravipudi
Greenhorn

Joined: Apr 04, 2012
Posts: 13
Hi Jeanne,
Actually thats not created in my project ,because i tried to get forums/list.page instead of installl.jsp ,some modification i have done in source code,because of not having install action that (jform-custom.conf) is not created.
I manually copied that file from another jforum project and...thats worked ,but the problem is if i copied that file into project(that is in eclipse) and build war file of my project,thats not working,when i manually copied only its working..

thanks Jeanne
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JForum Manual Database Setup
 
Similar Threads
Deadlock
JForum and Glassfish mysql
JForum on JBoss for the simple minded
test
can i install jforum under a shared hosing package