wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes Unknown protocol error while starting JBoss AS Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Unknown protocol error while starting JBoss AS" Watch "Unknown protocol error while starting JBoss AS" New topic
Author

Unknown protocol error while starting JBoss AS

Y D Prakash
Greenhorn

Joined: May 18, 2012
Posts: 5
Hi,

I am running JBoss-jboss-5.0.0.GA in Japanese machine. It is throwing the exception as :"java.lang.ExceptionInInitializerError: java.net.MalformedURLException: unknown protocol: c".

The JBOSS_HOME has Japanese characters.

[Works fine with JBOSS_HOME having English characters.]

Any idea what could be the reason for the above exception?
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10289
    
168

Welcome to the forums!

Can you please post the entire exception stacktrace and the command you use to start the server? Also what's the path where JBoss AS is installed on the file system?

P.S: While posting logs please wrap them in a Code block (you'll find a button in the message editor window), to properly format it.

[My Blog] [JavaRanch Journal]
Y D Prakash
Greenhorn

Joined: May 18, 2012
Posts: 5
Thanks Jaikiran for the quick reply.

Here is where the JBoss AS is installed: C:\Program Files\新しいフォルダ. Hope the Japanese characters will be displayed properly. [PFA, to see the JBoss AS Installation path]

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10289
    
168

Y D Prakash wrote:Thanks Jaikiran for the quick reply.

Here is where the JBoss AS is installed: C:\Program Files\新しいフォルダ. Hope the Japanese characters will be displayed properly. [PFA, to see the JBoss AS Installation path]


As a first step, move the JBoss AS installation out of the folder containing spaces in its path name. So move it out of C:\Program Files\新しいフォルダ to maybe C:\新しいフォルダ

Y D Prakash
Greenhorn

Joined: May 18, 2012
Posts: 5
Hi Jaikiran,

With "C:\新しいフォルダ\jboss-5.0.0.GA", JBoss did not start, where as with "C:\Program Files\jboss-5.0.0.GA" I am able to start JBoss in Japanese machine.

It looks like space is not an issue in the path.

Any idea?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unknown protocol error while starting JBoss AS