aspose file tools*
The moose likes Websphere and the fly likes Error when accessing application Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Error when accessing application" Watch "Error when accessing application" New topic
Author

Error when accessing application

Mary Koh
Ranch Hand

Joined: Feb 19, 2012
Posts: 33
Hi,

I am using WebSphere 7.0. Enterprise project is JavaEE 6.. It get deployed successfully. However, when I get the following error when I tried to access the application.

[5/18/12 17:58:02:874 SGT] 00000016 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E: Uncaught exception created in one of the service methods of the servlet Faces Servlet in application Belsize. Exception created : java.lang.NoSuchMethodError: com/sun/faces/util/Util.verifyFactoriesAndInitDefaultRenderKit(Ljavax/servlet/ServletContext;)V
at com.ibm.faces.context.MultipartFacesContextFactoryImpl.getFacesContext(MultipartFacesContextFactoryImpl.java:73)
at javax.faces.webapp.FacesServlet.service(FacesServlet.java:260)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1657)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:939)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:502)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:179)
at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3935)
at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:276)
at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:931)
at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1592)
at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:186)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:452)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewRequest(HttpInboundLink.java:511)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.processRequest(HttpInboundLink.java:305)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:276)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminators(NewConnectionInitialReadCallback.java:214)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:113)
at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Mikalai Zaikin
Ranch Hand

Joined: Jun 04, 2002
Posts: 3204
    
    5
Mary Koh wrote:Hi,

I am using WebSphere 7.0. Enterprise project is JavaEE 6.. It get deployed successfully. However, when I get the following error when I tried to access the application.



Hi Mary,

Sidenote: IIRC WAS 7 supports only Java EE5, not Java EE6.

Regarding your problem: this seems to be a JARs conflict (like WAS7 libraries have outdated JAR, and your Application requires newer).

In this case you can put the newer JAR into WEB-INF/lib folder of your WAR and set up WAS ClassLoader policy to PARENT_LAST, so your Application's JARs loaded first.

There are some threads about similar problem, take a look here for example.

Best regards,
MZ


Free SCDJWS 5.0 Study Guide - SCDJWS 5.0 Quiz (How to get SCDJWS 5.0 Quiz)
Java Platform, Enterprise Edition 6 Web Services Developer Certified Expert Exam Study Guide and Quiz
Mary Koh
Ranch Hand

Joined: Feb 19, 2012
Posts: 33
Hi MZ,

I have an enterprise project Java EE5 before I switched to Java EE6. Thanks for the note that Java EE5 is applicable for WebSphere 7.0.
I saw the link in your previous post. However, I am not familiar with shared library. Could you guide me along with it?
I am unclear of what I should do for step 2-4.

1 - You will need el-api.jar, jsf-api.jar, jsf-imp.jar and jstl.jar for Java Server Faces 1.1
2 - You will put the jars on WEB-INF/lib, as a shared library referenced by your Web Module or as references of optional-package declarations
3 - After deploying the application, change the value of the EAR ClassLoader to PARENT_LAST (Classes loaded with application class loader first option)
4 - Verify that this configuration is replicated to the WEB module classloader configuration, if not, change there also to "Classes loaded with application class loader first"
5 - Start / Restart de Web application
6 - Enjoy ;-)


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error when accessing application