aspose file tools*
The moose likes Security and the fly likes controls require LDAPv3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Engineering » Security
Bookmark "controls require LDAPv3" Watch "controls require LDAPv3" New topic
Author

controls require LDAPv3

Madhav Kanneganti
Greenhorn

Joined: Jan 20, 2012
Posts: 25
We are getting this error when we search for an attribute on openLDAP, what is this issue and how does this going to fix it?
William P O'Sullivan
Ranch Hand

Joined: Mar 28, 2012
Posts: 859

From what I recall working with LDAP,

LDAPv3 added a wealth of new features.

The message is telling you this.

WP
Madhav Kanneganti
Greenhorn

Joined: Jan 20, 2012
Posts: 25
hi WP,
How do we fix this from java? Is really problem with java what we use (1.6.x) version?
William P O'Sullivan
Ranch Hand

Joined: Mar 28, 2012
Posts: 859

No. Java 1.6 is the most modern version of Java.

The problem is you appear to be either using a newer v3 LDAP API with a v2 directory, or opposite.

WP
Madhav Kanneganti
Greenhorn

Joined: Jan 20, 2012
Posts: 25
How do we figure out which api version we are using, because we used simple JNDI code to connect to LDAP.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: controls require LDAPv3