aspose file tools*
The moose likes Websphere and the fly likes Web Service issue in WebSphere Application Server 8 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Web Service issue in WebSphere Application Server 8 " Watch "Web Service issue in WebSphere Application Server 8 " New topic
Author

Web Service issue in WebSphere Application Server 8

Sadiq ali Sirajudeen
Greenhorn

Joined: Apr 10, 2012
Posts: 1
Hi,

We are migrating the WebSphere application server from version 6 to 8. Due to this the application which were deployed in WAS 6 should be migrated from java 1.4 to 1.6. I am working in one of the application and I compiled the whole application with java 1.6 and generated EAR file and deployed in WAS 8. Inside the application, we use a web service link. This webservice link is broken and its not working after the deployment. Find below the logs which we got after deploying the application (java 1.6 version) in WAS 8,


5/29/12 11:42:47:669 GMT-03:00] 00000015 WSServerImpl E WSWS1002E: An error occurred while processing the Web services deployment descriptor for module: lib/AvonITS-ControllerWSWAR.war with error: java.lang.NullPointerException
at com.ibm.ws.classloader.CompoundClassLoader.loadClass(CompoundClassLoader.java:547)
at java.lang.ClassLoader.loadClass(ClassLoader.java:627)
at com.ibm.ws.webservices.component.WSServerImpl.setupWsddPort(WSServerImpl.java:1172)
at com.ibm.ws.webservices.component.WSServerImpl.warMetaDataCreated(WSServerImpl.java:2137)
at com.ibm.ws.webservices.component.WSServerImpl.metaDataCreated(WSServerImpl.java:638)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.fireMetaDataCreated(MetaDataMgrImpl.java:279)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.fireMetaDataCreated(MetaDataMgrImpl.java:262)
at com.ibm.ws.webcontainer.metadata.WebMetaDataFactory.createMetaData(WebMetaDataFactory.java:254)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.createMetaDataFromFactories(MetaDataMgrImpl.java:228)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.createMetaData(MetaDataMgrImpl.java:411)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:630)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:967)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:766)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2153)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:445)
at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:388)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$500(CompositionUnitMgrImpl.java:116)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:994)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:349)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1659)

Thanks,
Sadiq
 
Don't get me started about those stupid light bulbs.
 
subject: Web Service issue in WebSphere Application Server 8