Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WSAD 5.1.2 - Database Alias Name or DB name could not be found

 
Rob Clawson
Greenhorn
Posts: 2
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just got handed some very old code to do some maintenance on. Using WSAD 5.1.2. I have a couple of data sources defined that work with no problem. When I go to update these to point to a different test server, I get this error (in the Admin console - Test Connection):

Test Connection failed for datasource Data source 1 on server server1 at node localhost with the following exception: java.lang.Exception: com.ibm.db2.jcc.b.nm: [jcc][4038][12241][3.50.152] T2LUW exception: SQL1013N The database alias name or database name "NEW_DB" could not be found. SQLSTATE=42705 ERRORCODE=-1013, SQLSTATE=42705. View JVM logs for further details.

When updating the datasource definition for the new server, here's what I did:

1. Updated Security->JAAS Authentication Entries -> my_entry with new user Id/password
2. Updated Data Source -> DB2 Universal JDBC Driver Provider (XA) -> MyDataSource->Resource Properties
- updated databaseName
- updated serverName
- updated portNumber

I've restarted the server and restarted the IDE, but still get this error. I have verified that the connection information is correct by connecting via DBVisualizer.

I must be missing something that I need to change, but can't figure out what it might be. Any ideas?

Thanks,
Rob
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic