Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to publish EAR onto Websphere

 
Tj Randall
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Running Rational Application Developer for WebSphere Software (v. 8.0.4.1) on Windows. I have a EAR project that I'm trying to deploy to my Websphere server running on my machine. The EAR project references a WAR project. It *looks* like the WAR deploys successfully, but then the EAR deployment fails.

When tying to deploy, I get messages - any/all help is GREATLY appreciated!


!ENTRY org.eclipse.wst.server.core 4 0 2012-06-19 09:24:57.818
!MESSAGE Publishing failed
!SUBENTRY 1 com.ibm.etools.server.task.ejbdeploy 0 0 2012-06-19 09:24:57.818
!MESSAGE deploySuccess
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:24:57.818
!MESSAGE Error in delegate
!STACK 0
java.lang.NullPointerException
at com.ibm.etools.webtools.sdo.deploy.internal.cloudscape.DisconnectTaskDelegate.execute(Unknown Source)
at org.eclipse.wst.server.core.internal.Publisher.execute(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.executePublishers(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
!SUBENTRY 1 unknown 0 0 2012-06-19 09:24:57.818
!MESSAGE OK
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:24:57.818
!MESSAGE Could not publish to the server.
!STACK 0
java.lang.NullPointerException
at com.ibm.ws.ast.st.core.internal.GenericModuleSupportExtensionHelper.getModuleSupportClasses(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishGenericModules(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishModules(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)

!ENTRY org.eclipse.wst.server.core 4 0 2012-06-19 09:27:17.931
!MESSAGE Publishing failed
!SUBENTRY 1 com.ibm.etools.server.task.ejbdeploy 0 0 2012-06-19 09:27:17.931
!MESSAGE deploySuccess
!SUBENTRY 2 org.eclipse.jst.j2ee 0 0 2012-06-19 09:27:17.931
!MESSAGE Deploying crmtoas400ws
!SUBENTRY 3 0 0 2012-06-19 09:27:17.931
!MESSAGE Deployment from com.ibm.ast.ws.jaxws.deployer.JAXWSDeployer completed successfully
!SUBENTRY 3 0 0 2012-06-19 09:27:17.931
!MESSAGE Deployment from com.ibm.ast.ws.deployer.WSDeployer completed successfully
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:27:17.931
!MESSAGE Error in delegate
!STACK 0
java.lang.NullPointerException
at com.ibm.etools.webtools.sdo.deploy.internal.cloudscape.DisconnectTaskDelegate.execute(Unknown Source)
at org.eclipse.wst.server.core.internal.Publisher.execute(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.executePublishers(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
!SUBENTRY 1 unknown 0 0 2012-06-19 09:27:17.931
!MESSAGE OK
!SUBENTRY 1 unknown 0 0 2012-06-19 09:27:17.931
!MESSAGE OK
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:27:17.931
!MESSAGE Could not publish to the server.
!STACK 0
java.lang.NullPointerException
at com.ibm.ws.ast.st.core.internal.GenericModuleSupportExtensionHelper.getModuleSupportClasses(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishGenericModules(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishModules(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)

!ENTRY org.eclipse.wst.server.core 4 0 2012-06-19 09:28:07.977
!MESSAGE Publishing failed
!SUBENTRY 1 com.ibm.etools.server.task.ejbdeploy 0 0 2012-06-19 09:28:07.977
!MESSAGE deploySuccess
!SUBENTRY 2 org.eclipse.jst.j2ee 0 0 2012-06-19 09:28:07.977
!MESSAGE Deploying crmtoas400ws
!SUBENTRY 3 0 0 2012-06-19 09:28:07.977
!MESSAGE Deployment from com.ibm.ast.ws.jaxws.deployer.JAXWSDeployer completed successfully
!SUBENTRY 3 0 0 2012-06-19 09:28:07.977
!MESSAGE Deployment from com.ibm.ast.ws.deployer.WSDeployer completed successfully
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:28:07.977
!MESSAGE Error in delegate
!STACK 0
java.lang.NullPointerException
at com.ibm.etools.webtools.sdo.deploy.internal.cloudscape.DisconnectTaskDelegate.execute(Unknown Source)
at org.eclipse.wst.server.core.internal.Publisher.execute(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.executePublishers(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
!SUBENTRY 1 unknown 0 0 2012-06-19 09:28:07.977
!MESSAGE OK
!SUBENTRY 1 unknown 0 0 2012-06-19 09:28:07.977
!MESSAGE OK
!SUBENTRY 1 org.eclipse.wst.server.core 4 0 2012-06-19 09:28:07.977
!MESSAGE Could not publish to the server.
!STACK 0
java.lang.NullPointerException
at com.ibm.ws.ast.st.core.internal.GenericModuleSupportExtensionHelper.getModuleSupportClasses(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishGenericModules(Unknown Source)
at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.publishModules(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(Unknown Source)
at org.eclipse.wst.server.core.internal.Server.publishImpl(Unknown Source)
at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34410
346
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tj,
Welcome to CodeRanch!

Unfortunately, this is going to take some troubleshooting. Are you able to deploy any EAR to the server? (If you have another one around, try it. If not, make the simplest ear that can exist. One war with one file and no dependencies.)

At this point, you know if the problem is in your ear or on the server. If the former, keep adding stuff until you know what causes it. If the later, try recreating the server profile (or re-installing RAD.)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic